about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorPeder Bergebakken Sundt <pbsds@hotmail.com>2023-11-22 17:09:21 +0100
committerGitHub <noreply@github.com>2023-11-22 17:09:21 +0100
commit8895355442afeddac3bf4304b7bae465a4e776d7 (patch)
treed32b63e6a10d85bcaaeb9114e8b5fb79146f3643 /pkgs/by-name
parentc8208d43fd136f49604bfc616945b60943b6f080 (diff)
parent1e0e27fbba0dc3f4693df1f11ba546404ecc9c52 (diff)
downloadnixlib-8895355442afeddac3bf4304b7bae465a4e776d7.tar
nixlib-8895355442afeddac3bf4304b7bae465a4e776d7.tar.gz
nixlib-8895355442afeddac3bf4304b7bae465a4e776d7.tar.bz2
nixlib-8895355442afeddac3bf4304b7bae465a4e776d7.tar.lz
nixlib-8895355442afeddac3bf4304b7bae465a4e776d7.tar.xz
nixlib-8895355442afeddac3bf4304b7bae465a4e776d7.tar.zst
nixlib-8895355442afeddac3bf4304b7bae465a4e776d7.zip
Merge pull request #265694 from surfaceflinger/feather
feather: init at 2.5.2
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/fe/feather/package.nix84
1 files changed, 84 insertions, 0 deletions
diff --git a/pkgs/by-name/fe/feather/package.nix b/pkgs/by-name/fe/feather/package.nix
new file mode 100644
index 000000000000..5224d5157a96
--- /dev/null
+++ b/pkgs/by-name/fe/feather/package.nix
@@ -0,0 +1,84 @@
+{ boost
+, cmake
+, fetchFromGitHub
+, hidapi
+, lib
+, libsodium
+, libusb1
+, openssl
+, pkg-config
+, protobuf
+, qrencode
+, qt6
+, readline
+, stdenv
+, testers
+, tor
+, unbound
+, zxing-cpp
+}:
+
+stdenv.mkDerivation (finalAttrs: {
+  pname = "feather";
+  version = "2.5.2";
+
+  src = fetchFromGitHub {
+    owner = "feather-wallet";
+    repo = "feather";
+    rev = finalAttrs.version;
+    hash = "sha256-OSBG2W35GYlViwz5eXokpScrMTtPSaWAgEUNw2urm6w=";
+    fetchSubmodules = true;
+  };
+
+  nativeBuildInputs = [
+    cmake
+    pkg-config
+    qt6.wrapQtAppsHook
+  ];
+
+  buildInputs = [
+    boost
+    hidapi
+    libsodium
+    libusb1
+    openssl
+    protobuf
+    qrencode
+    unbound
+    zxing-cpp
+  ] ++ (with qt6; [
+    qtbase
+    qtmultimedia
+    qtsvg
+    qttools
+    qtwayland
+    qtwebsockets
+  ]);
+
+  cmakeFlags = [
+    "-DProtobuf_INCLUDE_DIR=${lib.getDev protobuf}/include"
+    "-DProtobuf_PROTOC_EXECUTABLE=${lib.getExe protobuf}"
+    "-DReadline_INCLUDE_DIR=${lib.getDev readline}/include/readline"
+    "-DReadline_LIBRARY=${lib.getLib readline}/lib/libreadline.so"
+    "-DReadline_ROOT_DIR=${lib.getDev readline}"
+    "-DTOR_DIR=${lib.makeBinPath [ tor ]}"
+    "-DTOR_VERSION=${tor.version}"
+  ];
+
+  passthru.tests.version = testers.testVersion {
+    package = finalAttrs.finalPackage;
+    command = ''
+      QT_QPA_PLATFORM=minimal ${finalAttrs.finalPackage.meta.mainProgram} --version
+    '';
+  };
+
+  meta = with lib; {
+    description = "A free Monero desktop wallet";
+    homepage = "https://featherwallet.org/";
+    changelog = "https://featherwallet.org/changelog/#${finalAttrs.version}%20changelog";
+    platforms = platforms.linux;
+    license = licenses.bsd3;
+    mainProgram = "feather";
+    maintainers = with maintainers; [ surfaceflinger ];
+  };
+})