about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorAnderson Torres <torres.anderson.85@protonmail.com>2023-11-21 00:35:18 -0300
committerAnderson Torres <torres.anderson.85@protonmail.com>2023-11-23 12:40:23 -0300
commit7b6ec1bc82d0eae4f628b6301fd3b03d19c23d94 (patch)
tree97fed947cafc8cf2f129b93d4846ead661e7e4ad /pkgs/by-name
parenteead97a9b2a7948beb64c11b2d2430a2b538d75e (diff)
downloadnixlib-7b6ec1bc82d0eae4f628b6301fd3b03d19c23d94.tar
nixlib-7b6ec1bc82d0eae4f628b6301fd3b03d19c23d94.tar.gz
nixlib-7b6ec1bc82d0eae4f628b6301fd3b03d19c23d94.tar.bz2
nixlib-7b6ec1bc82d0eae4f628b6301fd3b03d19c23d94.tar.lz
nixlib-7b6ec1bc82d0eae4f628b6301fd3b03d19c23d94.tar.xz
nixlib-7b6ec1bc82d0eae4f628b6301fd3b03d19c23d94.tar.zst
nixlib-7b6ec1bc82d0eae4f628b6301fd3b03d19c23d94.zip
wio: init at unstable-2023-05-28
A resurrection.
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/wi/wio/package.nix76
1 files changed, 76 insertions, 0 deletions
diff --git a/pkgs/by-name/wi/wio/package.nix b/pkgs/by-name/wi/wio/package.nix
new file mode 100644
index 000000000000..73255a38208b
--- /dev/null
+++ b/pkgs/by-name/wi/wio/package.nix
@@ -0,0 +1,76 @@
+{ lib
+, stdenv
+, fetchFromGitHub
+, alacritty
+, cage
+, cairo
+, libxkbcommon
+, makeWrapper
+, mesa
+, meson
+, ninja
+, pkg-config
+, udev
+, unstableGitUpdater
+, wayland
+, wayland-protocols
+, wlroots
+, xwayland
+}:
+
+stdenv.mkDerivation (finalAttrs: {
+  pname = "wio";
+  version = "unstable-2023-05-28";
+
+  src = fetchFromGitHub {
+    owner = "Rubo3";
+    repo = "wio";
+    rev = "9d33d60839d3005ee16b5b04ae7f42c049939058";
+    hash = "sha256-ylJ8VHQU4TWLrhxGRo6HHOB7RWTVAThMQRw0uAFboNE=";
+  };
+
+  nativeBuildInputs = [
+    makeWrapper
+    meson
+    ninja
+    pkg-config
+  ];
+
+  buildInputs = [
+    cairo
+    libxkbcommon
+    mesa
+    udev
+    wayland
+    wayland-protocols
+    wlroots
+    xwayland
+  ];
+
+  strictDeps = false; # why is it so hard?
+
+  env.NIX_CFLAGS_COMPILE = "-Wno-error=maybe-uninitialized";
+
+  postInstall = ''
+    wrapProgram $out/bin/wio \
+      --prefix PATH ":" "${lib.makeBinPath [ alacritty cage ]}"
+  '';
+
+  passthru = {
+    providedSessions = [ "wio" ];
+    updateScript = unstableGitUpdater { };
+  };
+
+  meta = {
+    homepage = "https://github.com/Rubo3/wio";
+    description = "Wayland compositor similar to Plan 9's rio";
+    longDescription = ''
+      Wio is a Wayland compositor for Linux and FreeBSD which has a similar look
+      and feel to plan9's rio.
+    '';
+    license = with lib.licenses; [ bsd3 ];
+    mainProgram = "wio";
+    maintainers = with lib.maintainers; [ AndersonTorres ];
+    inherit (wayland.meta) platforms;
+  };
+})