about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorGustavo Coutinho de Souza <dev@onemoresuza.mailer.me>2023-11-29 16:36:26 -0300
committerGustavo Coutinho de Souza <dev@onemoresuza.mailer.me>2023-12-15 07:19:46 -0300
commit7ac8a22e971ee850111ddc48ab926640200755e3 (patch)
treec76be4ec76dcfb71f2fb6f4f49b17ab43432ef71 /pkgs/by-name
parent39bbee99ffc7e2f0c34c395beb7f6a699230d5af (diff)
downloadnixlib-7ac8a22e971ee850111ddc48ab926640200755e3.tar
nixlib-7ac8a22e971ee850111ddc48ab926640200755e3.tar.gz
nixlib-7ac8a22e971ee850111ddc48ab926640200755e3.tar.bz2
nixlib-7ac8a22e971ee850111ddc48ab926640200755e3.tar.lz
nixlib-7ac8a22e971ee850111ddc48ab926640200755e3.tar.xz
nixlib-7ac8a22e971ee850111ddc48ab926640200755e3.tar.zst
nixlib-7ac8a22e971ee850111ddc48ab926640200755e3.zip
treecat: init at 1.0.2-unstable-2023-11-28
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/tr/treecat/package.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/pkgs/by-name/tr/treecat/package.nix b/pkgs/by-name/tr/treecat/package.nix
new file mode 100644
index 000000000000..df184b9d1062
--- /dev/null
+++ b/pkgs/by-name/tr/treecat/package.nix
@@ -0,0 +1,47 @@
+{ stdenv
+, fetchFromSourcehut
+, hare
+, haredo
+, lib
+, scdoc
+}:
+stdenv.mkDerivation (finalAttrs: {
+  pname = "treecat";
+  version = "1.0.2-unstable-2023-11-28";
+
+  outputs = [ "out" "man" ];
+
+  src = fetchFromSourcehut {
+    owner = "~autumnull";
+    repo = "treecat";
+    rev = "d277aed99eb48eef891b76916a61029989c41d2d";
+    hash = "sha256-4A01MAGkBSSzkyRw4omNbLoX8z+pHfoUO7/6QvEUu70=";
+  };
+
+  nativeBuildInputs = [
+    hare
+    haredo
+    scdoc
+  ];
+
+  dontConfigure = true;
+
+  preBuild = ''
+    HARECACHE="$(mktemp -d)"
+    export HARECACHE
+    export PREFIX="${builtins.placeholder "out"}"
+  '';
+
+  meta = {
+    description = "Serialize a directory to a tree diagram, and vice versa";
+    longDescription = ''
+      Treecat is an amalgamation of `tree(1)` and `cat(1)`, with the added
+      bonus that it can reconstruct its output back into the original filetree.
+    '';
+    homepage = "https://sr.ht/~autumnull/treecat/";
+    license = lib.licenses.wtfpl;
+    maintainers = with lib.maintainers; [ onemoresuza ];
+    mainProgram = "treecat";
+    inherit (hare.meta) platforms badPlatforms;
+  };
+})