about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorWeijia Wang <9713184+wegank@users.noreply.github.com>2024-03-14 19:17:00 +0100
committerGitHub <noreply@github.com>2024-03-14 19:17:00 +0100
commit7826c4ffaa4c473bf7f804d312faf27f08c5a409 (patch)
tree897d84aea78946f3eb5c144ac3fdc47a4fcccd12 /pkgs/by-name
parent22d6f54966e8b97986edfcc8757180ad0fcd9899 (diff)
parent0a3812d6b64cf28f817c2ca07304ca16c46e21af (diff)
downloadnixlib-7826c4ffaa4c473bf7f804d312faf27f08c5a409.tar
nixlib-7826c4ffaa4c473bf7f804d312faf27f08c5a409.tar.gz
nixlib-7826c4ffaa4c473bf7f804d312faf27f08c5a409.tar.bz2
nixlib-7826c4ffaa4c473bf7f804d312faf27f08c5a409.tar.lz
nixlib-7826c4ffaa4c473bf7f804d312faf27f08c5a409.tar.xz
nixlib-7826c4ffaa4c473bf7f804d312faf27f08c5a409.tar.zst
nixlib-7826c4ffaa4c473bf7f804d312faf27f08c5a409.zip
Merge pull request #295816 from Aleksanaa/switcheroo
switcheroo: 2.0.1 -> 2.1.0
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/sw/switcheroo/package.nix20
1 files changed, 16 insertions, 4 deletions
diff --git a/pkgs/by-name/sw/switcheroo/package.nix b/pkgs/by-name/sw/switcheroo/package.nix
index 4c41d6739824..9d2327f4095a 100644
--- a/pkgs/by-name/sw/switcheroo/package.nix
+++ b/pkgs/by-name/sw/switcheroo/package.nix
@@ -1,6 +1,7 @@
 { lib
 , blueprint-compiler
 , cargo
+, darwin
 , desktop-file-utils
 , fetchFromGitLab
 , glib
@@ -17,19 +18,19 @@
 
 stdenv.mkDerivation (finalAttrs: {
   pname = "switcheroo";
-  version = "2.0.1";
+  version = "2.1.0";
 
   src = fetchFromGitLab {
     owner = "adhami3310";
     repo = "Switcheroo";
     rev = "v${finalAttrs.version}";
-    hash = "sha256-3JlI0Co3yuD6fKaKlmz1Vg0epXABO+7cRvm6/PgbGUE=";
+    hash = "sha256-hopN2ynksaYoNYjXrh7plmhfmGYyqqK75GOtbsE95ZY=";
   };
 
   cargoDeps = rustPlatform.fetchCargoTarball {
     src = finalAttrs.src;
     name = "switcheroo-${finalAttrs.version}";
-    hash = "sha256-wC57VTJGiN2hDL2Z9fFw5H9c3Txqh30AHfR9o2DbcSk=";
+    hash = "sha256-wN6MsiOgYFgzDzdGei0ptRbG+h+xMJiFfzCcg6Xtryw=";
   };
 
   nativeBuildInputs = [
@@ -48,8 +49,19 @@ stdenv.mkDerivation (finalAttrs: {
     glib
     gtk4
     libadwaita
+  ] ++ lib.optionals stdenv.isDarwin [
+    darwin.apple_sdk.frameworks.Foundation
   ];
 
+  # Workaround for the gettext-sys issue
+  # https://github.com/Koka/gettext-rs/issues/114
+  env.NIX_CFLAGS_COMPILE = lib.optionalString
+    (
+      stdenv.cc.isClang &&
+      lib.versionAtLeast stdenv.cc.version "16"
+    )
+    "-Wno-error=incompatible-function-pointer-types";
+
   meta = with lib; {
     changelog = "https://gitlab.com/adhami3310/Switcheroo/-/releases/v${finalAttrs.version}";
     description = "An app for converting images between different formats";
@@ -57,6 +69,6 @@ stdenv.mkDerivation (finalAttrs: {
     license = licenses.gpl3Plus;
     mainProgram = "switcheroo";
     maintainers = with maintainers; [ michaelgrahamevans ];
-    platforms = platforms.linux;
+    platforms = platforms.unix;
   };
 })