about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorPeder Bergebakken Sundt <pbsds@hotmail.com>2023-12-09 21:27:42 +0100
committerGitHub <noreply@github.com>2023-12-09 21:27:42 +0100
commit72a301c09faf7c060cae8ba45556542c124aeb62 (patch)
tree930bc5cfb22d4cc3a70da5e2eedea0852172bf98 /pkgs/by-name
parent45367f221aafecf43436fde6967269e87e1bbf6f (diff)
parent63dce721985fac18d5e1b6bacb80fc3b36da9548 (diff)
downloadnixlib-72a301c09faf7c060cae8ba45556542c124aeb62.tar
nixlib-72a301c09faf7c060cae8ba45556542c124aeb62.tar.gz
nixlib-72a301c09faf7c060cae8ba45556542c124aeb62.tar.bz2
nixlib-72a301c09faf7c060cae8ba45556542c124aeb62.tar.lz
nixlib-72a301c09faf7c060cae8ba45556542c124aeb62.tar.xz
nixlib-72a301c09faf7c060cae8ba45556542c124aeb62.tar.zst
nixlib-72a301c09faf7c060cae8ba45556542c124aeb62.zip
Merge pull request #266094 from ambroisie/add-vimix-cursors
vimix-cursors: init at 2021-09-18
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/vi/vimix-cursors/package.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/pkgs/by-name/vi/vimix-cursors/package.nix b/pkgs/by-name/vi/vimix-cursors/package.nix
new file mode 100644
index 000000000000..33de66e19e54
--- /dev/null
+++ b/pkgs/by-name/vi/vimix-cursors/package.nix
@@ -0,0 +1,55 @@
+{ lib
+, fetchFromGitHub
+, stdenvNoCC
+, inkscape
+, python3Packages
+, xcursorgen
+}:
+stdenvNoCC.mkDerivation {
+  pname = "vimix-cursors";
+  version = "2020-02-24-unstable-2021-09-18";
+
+  src = fetchFromGitHub {
+    owner = "vinceliuice";
+    repo = "vimix-cursors";
+    rev = "9bc292f40904e0a33780eda5c5d92eb9a1154e9c";
+    hash = "sha256-zW7nJjmB3e+tjEwgiCrdEe5yzJuGBNdefDdyWvgYIUU=";
+  };
+
+  nativeBuildInputs = [
+    inkscape
+    python3Packages.cairosvg
+    xcursorgen
+  ];
+
+  postPatch = ''
+    patchShebangs .
+  '';
+
+  buildPhase = ''
+    runHook preBuild
+
+    HOME="$NIX_BUILD_ROOT" ./build.sh
+
+    runHook postBuild
+  '';
+
+  installPhase = ''
+    runHook preInstall
+
+    install -dm 755 $out/share/icons
+    for color in "" "-white"; do
+      cp -pr "dist$color/"  "$out/share/icons/Vimix$color-cursors"
+    done
+
+    runHook postInstall
+  '';
+
+  meta = with lib; {
+    description = "An X cursor theme inspired by Materia design";
+    homepage = "https://github.com/vinceliuice/Vimix-cursors";
+    license = licenses.gpl3Only;
+    maintainers = with maintainers; [ ambroisie ];
+    platforms = platforms.linux;
+  };
+}