about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorEmery Hemingway <ehmry@posteo.net>2023-11-28 17:34:44 +0200
committerEmery Hemingway <ehmry@posteo.net>2023-12-10 09:25:34 +0000
commit6fb94a8e0f02696c831a6c161b0ba7cd6375c742 (patch)
treec2499dcfd7408d067e5041682adcac52160bdf0c /pkgs/by-name
parent0ee3c7813135bf471578e45d83b4b78c6b00d13d (diff)
downloadnixlib-6fb94a8e0f02696c831a6c161b0ba7cd6375c742.tar
nixlib-6fb94a8e0f02696c831a6c161b0ba7cd6375c742.tar.gz
nixlib-6fb94a8e0f02696c831a6c161b0ba7cd6375c742.tar.bz2
nixlib-6fb94a8e0f02696c831a6c161b0ba7cd6375c742.tar.lz
nixlib-6fb94a8e0f02696c831a6c161b0ba7cd6375c742.tar.xz
nixlib-6fb94a8e0f02696c831a6c161b0ba7cd6375c742.tar.zst
nixlib-6fb94a8e0f02696c831a6c161b0ba7cd6375c742.zip
alephone: 1.6.2 -> 1.7
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/al/alephone/package.nix151
1 files changed, 92 insertions, 59 deletions
diff --git a/pkgs/by-name/al/alephone/package.nix b/pkgs/by-name/al/alephone/package.nix
index 1bf732e446bf..44349b7621e5 100644
--- a/pkgs/by-name/al/alephone/package.nix
+++ b/pkgs/by-name/al/alephone/package.nix
@@ -1,72 +1,104 @@
-{ lib, stdenv, fetchurl, alsa-lib, boost, curl, ffmpeg_4, icoutils, libGLU
-, libmad, libogg, libpng, libsndfile, libvorbis, lua, miniupnpc, pkg-config
-, SDL2, SDL2_image, SDL2_net, SDL2_ttf, speex, zziplib, zlib, makeWrapper
-, makeDesktopItem, unzip, alephone }:
+{ lib
+, stdenv
+, fetchurl
+, alsa-lib
+, boost
+, curl
+, ffmpeg_4
+, icoutils
+, libGLU
+, libmad
+, libogg
+, libpng
+, libsndfile
+, libvorbis
+, lua
+, makeDesktopItem
+, makeWrapper
+, miniupnpc
+, openal
+, pkg-config
+, SDL2
+, SDL2_image
+, SDL2_net
+, SDL2_ttf
+, speex
+, unzip
+, zlib
+, zziplib
+, alephone
+}:
 
-let
-  self = stdenv.mkDerivation rec {
-    outputs = [ "out" "icons" ];
-    pname = "alephone";
-    version = "1.6.2";
+stdenv.mkDerivation (finalAttrs: {
+  outputs = [ "out" "icons" ];
+  pname = "alephone";
+  version = "1.7";
 
-    src = fetchurl {
-      url = let date = "20230529";
+  src = fetchurl {
+    url =
+      let date = "20231125";
       in "https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${date}/AlephOne-${date}.tar.bz2";
-      sha256 = "sha256-UqhZvOMOxU4W0eLRRTQvGXaqTpWD5KIdXULClHW7Iyc=";
-    };
+    sha256 = "sha256-qRHmtkzPi6PKeAzoMPdSbboiilG+L2fCXvXXu3vIchs=";
+  };
 
-    nativeBuildInputs = [ pkg-config icoutils ];
+  nativeBuildInputs = [ pkg-config icoutils ];
 
-    buildInputs = [
-      alsa-lib
-      boost
-      curl
-      ffmpeg_4
-      libGLU
-      libmad
-      libsndfile
-      libogg
-      libpng
-      libvorbis
-      lua
-      miniupnpc
-      SDL2
-      SDL2_image
-      SDL2_net
-      SDL2_ttf
-      speex
-      zziplib
-      zlib
-    ];
+  buildInputs = [
+    alsa-lib
+    boost
+    curl
+    ffmpeg_4
+    libGLU
+    libmad
+    libogg
+    libpng
+    libsndfile
+    libvorbis
+    lua
+    miniupnpc
+    openal
+    SDL2
+    SDL2_image
+    SDL2_net
+    SDL2_ttf
+    speex
+    zlib
+    zziplib
+  ];
 
-    configureFlags = [ "--with-boost-libdir=${boost.out}/lib" ];
-    makeFlags = [ "AR:=$(AR)" ];
+  configureFlags = [ "--with-boost-libdir=${boost.out}/lib" ];
+  makeFlags = [ "AR:=$(AR)" ];
 
-    enableParallelBuilding = true;
+  enableParallelBuilding = true;
 
-    postInstall = ''
-      mkdir $icons
-      icotool -x -i 5 -o $icons Resources/Windows/*.ico
-      pushd $icons
-      for x in *_5_48x48x32.png; do
-        mv $x ''${x%_5_48x48x32.png}.png
-      done
-      popd
-    '';
+  postInstall = ''
+    mkdir $icons
+    icotool -x -i 5 -o $icons Resources/Windows/*.ico
+    pushd $icons
+    for x in *_5_48x48x32.png; do
+      mv $x ''${x%_5_48x48x32.png}.png
+    done
+    popd
+  '';
 
-    meta = with lib; {
-      description =
-        "Aleph One is the open source continuation of Bungie’s Marathon 2 game engine";
-      homepage = "https://alephone.lhowon.org/";
-      license = with licenses; [ gpl3 ];
-      maintainers = with maintainers; [ ehmry ];
-      platforms = platforms.linux;
-    };
+  meta = {
+    description =
+      "Aleph One is the open source continuation of Bungie’s Marathon 2 game engine";
+    homepage = "https://alephone.lhowon.org/";
+    license = [ lib.licenses.gpl3 ];
+    maintainers = with lib.maintainers; [ ehmry ];
+    platforms = lib.platforms.linux;
   };
 
-in self // {
-  makeWrapper = { pname, desktopName, version, zip, meta
-    , icon ? alephone.icons + "/alephone.png", ... }@extraArgs:
+  passthru.makeWrapper =
+    { pname
+    , desktopName
+    , version
+    , zip
+    , meta
+    , icon ? alephone.icons + "/alephone.png"
+    , ...
+    }@extraArgs:
     stdenv.mkDerivation ({
       inherit pname version;
 
@@ -96,7 +128,8 @@ in self // {
     } // extraArgs // {
       meta = alephone.meta // {
         license = lib.licenses.free;
+        mainProgram = pname;
         hydraPlatforms = [ ];
       } // meta;
     });
-}
+})