about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorPeder Bergebakken Sundt <pbsds@hotmail.com>2024-03-14 17:00:16 +0100
committerGitHub <noreply@github.com>2024-03-14 17:00:16 +0100
commit4ea4e37e147d5848f6a44726f8a3c5b00fa19307 (patch)
tree53830713f4a613adee85e296c5347c630e8d5226 /pkgs/by-name
parent006444593333a5fd2ac35298afda93fac77d5ac8 (diff)
parent6cabf8e212d0bb63da63917a97299bfbea0c576a (diff)
downloadnixlib-4ea4e37e147d5848f6a44726f8a3c5b00fa19307.tar
nixlib-4ea4e37e147d5848f6a44726f8a3c5b00fa19307.tar.gz
nixlib-4ea4e37e147d5848f6a44726f8a3c5b00fa19307.tar.bz2
nixlib-4ea4e37e147d5848f6a44726f8a3c5b00fa19307.tar.lz
nixlib-4ea4e37e147d5848f6a44726f8a3c5b00fa19307.tar.xz
nixlib-4ea4e37e147d5848f6a44726f8a3c5b00fa19307.tar.zst
nixlib-4ea4e37e147d5848f6a44726f8a3c5b00fa19307.zip
Merge pull request #275402 from mightyiam/git-fixup
git-instafix: init at 0.2.1
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/gi/git-instafix/package.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/pkgs/by-name/gi/git-instafix/package.nix b/pkgs/by-name/gi/git-instafix/package.nix
new file mode 100644
index 000000000000..9085d381ff2d
--- /dev/null
+++ b/pkgs/by-name/gi/git-instafix/package.nix
@@ -0,0 +1,42 @@
+{ git
+, lib
+, libgit2
+, makeWrapper
+, rustPlatform
+, stdenv
+, fetchFromGitHub
+}:
+let
+  inherit
+    (lib)
+    licenses
+    maintainers
+    ;
+
+  version = "0.2.1";
+in
+rustPlatform.buildRustPackage {
+  pname = "git-instafix";
+  inherit version;
+
+  src = fetchFromGitHub {
+    owner = "quodlibetor";
+    repo = "git-instafix";
+    rev = "v${version}";
+    hash = "sha256-rWHiaZji3GECsiMqvEGC/tF+K29ZLlY6+TCNxtixHQo=";
+  };
+
+  cargoHash = "sha256-t5vlr3YxjRPqMHwPqVjWul4RdSg0hiTWUQxcJmGKiTQ=";
+
+  buildInputs = [ libgit2 ];
+  nativeCheckInputs = [ git ];
+
+  meta = {
+    description = "Quickly fix up an old commit using your currently-staged changes";
+    homepage = "https://github.com/quodlibetor/git-instafix";
+    license = with licenses; [ mit asl20 ];
+    maintainers = with maintainers; [ mightyiam ];
+    changelog = "https://github.com/quodlibetor/git-instafix/releases/tag/v${version}";
+    broken = stdenv.isDarwin;
+  };
+}