about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorVonixxx <vonixxxwork@tuta.io>2023-11-17 09:05:40 +0100
committerVonixxx <vonixxxwork@tuta.io>2023-12-13 22:08:39 +0100
commit38fe5aa511994eaa3c695b96f5851793ccaa62e3 (patch)
treedac7b98db594f5e739f48868373436b8fff1cf65 /pkgs/by-name
parent6abc77ca5ceef471ecdf94afe58e62b2466bfe4a (diff)
downloadnixlib-38fe5aa511994eaa3c695b96f5851793ccaa62e3.tar
nixlib-38fe5aa511994eaa3c695b96f5851793ccaa62e3.tar.gz
nixlib-38fe5aa511994eaa3c695b96f5851793ccaa62e3.tar.bz2
nixlib-38fe5aa511994eaa3c695b96f5851793ccaa62e3.tar.lz
nixlib-38fe5aa511994eaa3c695b96f5851793ccaa62e3.tar.xz
nixlib-38fe5aa511994eaa3c695b96f5851793ccaa62e3.tar.zst
nixlib-38fe5aa511994eaa3c695b96f5851793ccaa62e3.zip
when: init at 1.1.45
when: init at 1.1.46

incorporated suggestions

when: init at 1.1.46

incorporated changes

fixed stdenv

incorporated changes

incorporated changes

incorporated changes

incorporated changes

fixed trailing whitespace
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/wh/when/package.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/pkgs/by-name/wh/when/package.nix b/pkgs/by-name/wh/when/package.nix
new file mode 100644
index 000000000000..65fe306f447f
--- /dev/null
+++ b/pkgs/by-name/wh/when/package.nix
@@ -0,0 +1,44 @@
+{ lib
+, stdenvNoCC
+, perl
+, installShellFiles
+, fetchFromBitbucket
+}:
+
+stdenvNoCC.mkDerivation (finalAttrs: {
+  pname   = "when";
+  version = "1.1.45";
+
+  src = fetchFromBitbucket {
+    repo  = "when";
+    owner = "ben-crowell";
+    rev   = finalAttrs.version;
+    hash  = "sha256-+ggYjY6/aTUrdvREn0TTQ4Pu/VR4QTjflDaicRXuOMs=";
+  };
+
+  buildInputs = [ perl ];
+
+  nativeBuildInputs = [ installShellFiles ];
+
+  postBuild = ''
+     pod2man $src/when when.1
+  '';
+
+  installPhase = ''
+     runHook preInstall
+
+     install -Dm755 when $out/bin/when
+     installManPage when.1
+
+     runHook postInstall
+  '';
+
+  meta = with lib; {
+    description = "An extremely simple personal calendar program";
+    homepage    = "https://www.lightandmatter.com/when/when.html";
+    license     = licenses.gpl2Only;
+    mainProgram = "when";
+    maintainers = with maintainers; [ vonixxx ];
+    platforms   = platforms.all;
+  };
+})