about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorWeijia Wang <9713184+wegank@users.noreply.github.com>2024-03-12 18:49:39 +0100
committerGitHub <noreply@github.com>2024-03-12 18:49:39 +0100
commit13da11d8f886c237204ddfaf59a3188e8ebaf82b (patch)
tree4f144f01c13bb17d1e4171a4d724258376d9d446 /pkgs/by-name
parentb35fc0188b2c285dcd431cb87ee35e31dfaa1461 (diff)
parent9e119fe382c098b89d57b687baff77bb0c006bb3 (diff)
downloadnixlib-13da11d8f886c237204ddfaf59a3188e8ebaf82b.tar
nixlib-13da11d8f886c237204ddfaf59a3188e8ebaf82b.tar.gz
nixlib-13da11d8f886c237204ddfaf59a3188e8ebaf82b.tar.bz2
nixlib-13da11d8f886c237204ddfaf59a3188e8ebaf82b.tar.lz
nixlib-13da11d8f886c237204ddfaf59a3188e8ebaf82b.tar.xz
nixlib-13da11d8f886c237204ddfaf59a3188e8ebaf82b.tar.zst
nixlib-13da11d8f886c237204ddfaf59a3188e8ebaf82b.zip
Merge pull request #294593 from wegank/nicotine-plus-gtk4
nicotine-plus: migrate to gtk4
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/ni/nicotine-plus/package.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/pkgs/by-name/ni/nicotine-plus/package.nix b/pkgs/by-name/ni/nicotine-plus/package.nix
new file mode 100644
index 000000000000..dad01456ba73
--- /dev/null
+++ b/pkgs/by-name/ni/nicotine-plus/package.nix
@@ -0,0 +1,54 @@
+{ lib
+, fetchFromGitHub
+, wrapGAppsHook4
+, gdk-pixbuf
+, gettext
+, gobject-introspection
+, gtk4
+, python3Packages
+}:
+
+python3Packages.buildPythonApplication rec {
+  pname = "nicotine-plus";
+  version = "3.3.2";
+
+  src = fetchFromGitHub {
+    owner = "nicotine-plus";
+    repo = "nicotine-plus";
+    rev = "refs/tags/${version}";
+    hash = "sha256-dl4fTa+CXsycC+hhSkIzQQxrSkBDPsdrmKdrHPakGig=";
+  };
+
+  nativeBuildInputs = [ gettext wrapGAppsHook4 gobject-introspection ];
+
+  propagatedBuildInputs = [
+    gdk-pixbuf
+    gobject-introspection
+    gtk4
+    python3Packages.pygobject3
+  ];
+
+  postInstall = ''
+    ln -s $out/bin/nicotine $out/bin/nicotine-plus
+  '';
+
+  preFixup = ''
+    gappsWrapperArgs+=(
+      --prefix XDG_DATA_DIRS : "${gtk4}/share/gsettings-schemas/${gtk4.name}"
+    )
+  '';
+
+  doCheck = false;
+
+  meta = with lib; {
+    description = "A graphical client for the SoulSeek peer-to-peer system";
+    longDescription = ''
+      Nicotine+ aims to be a pleasant, free and open source (FOSS) alternative
+      to the official Soulseek client, providing additional functionality while
+      keeping current with the Soulseek protocol.
+    '';
+    homepage = "https://www.nicotine-plus.org";
+    license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ klntsky ];
+  };
+}