about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorGuillaume Girol <symphorien+git@xlumurb.eu>2023-11-26 12:00:00 +0000
committerGuillaume Girol <symphorien+git@xlumurb.eu>2023-12-21 00:32:42 +0100
commit045b4f7276e36826a9030abe2bed85d8c65d2a19 (patch)
tree483d7de480398126af4e9a83abc2ba984099c71c /pkgs/by-name
parent5a09cb4b393d58f9ed0d9ca1555016a8543c2ac8 (diff)
downloadnixlib-045b4f7276e36826a9030abe2bed85d8c65d2a19.tar
nixlib-045b4f7276e36826a9030abe2bed85d8c65d2a19.tar.gz
nixlib-045b4f7276e36826a9030abe2bed85d8c65d2a19.tar.bz2
nixlib-045b4f7276e36826a9030abe2bed85d8c65d2a19.tar.lz
nixlib-045b4f7276e36826a9030abe2bed85d8c65d2a19.tar.xz
nixlib-045b4f7276e36826a9030abe2bed85d8c65d2a19.tar.zst
nixlib-045b4f7276e36826a9030abe2bed85d8c65d2a19.zip
nixseparatedebuginfod: init at 0.3.2
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/ni/nixseparatedebuginfod/package.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/pkgs/by-name/ni/nixseparatedebuginfod/package.nix b/pkgs/by-name/ni/nixseparatedebuginfod/package.nix
new file mode 100644
index 000000000000..85e1175d4512
--- /dev/null
+++ b/pkgs/by-name/ni/nixseparatedebuginfod/package.nix
@@ -0,0 +1,42 @@
+{ lib
+, fetchFromGitHub
+, rustPlatform
+, libarchive
+, openssl
+, sqlite
+, pkg-config
+}:
+
+rustPlatform.buildRustPackage rec {
+  pname = "nixseparatedebuginfod";
+  version = "0.3.2";
+
+  src = fetchFromGitHub {
+    owner = "symphorien";
+    repo = "nixseparatedebuginfod";
+    rev = "v${version}";
+    hash = "sha256-XSEHNoc3h21foVeR28KgfiBTRHyUh+GJ52LMD2xFHfA=";
+  };
+
+  cargoHash = "sha256-t6W6siHuga/T9kmanA735zH2i9eCOT7vD6v7E5LIp9k=";
+
+  # tests need a working nix install with access to the internet
+  doCheck = false;
+
+  buildInputs = [
+    libarchive
+    openssl
+    sqlite
+  ];
+
+  nativeBuildInputs = [ pkg-config ];
+
+  meta = with lib; {
+    description = "Downloads and provides debug symbols and source code for nix derivations to gdb and other debuginfod-capable debuggers as needed";
+    homepage = "https://github.com/symphorien/nixseparatedebuginfod";
+    license = licenses.gpl3Only;
+    maintainers = [ maintainers.symphorien ];
+    platforms = platforms.linux;
+    mainProgram = "nixseparatedebuginfod";
+  };
+}