about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorValentin Gagarin <valentin.gagarin@tweag.io>2024-01-13 20:51:37 +0100
committerGitHub <noreply@github.com>2024-01-13 20:51:37 +0100
commitfd78de6eeb06d674c9a4b8176c44d8baaca8cb9f (patch)
treeed0aba82d9d2339ce22051ade5f5dcfb2eb57528 /pkgs/build-support
parent76a31fdb5c4fea3852c36067e6383362094eb7de (diff)
parent0530d6bd0498e6f554cc9070a163ac9aec5819c8 (diff)
downloadnixlib-fd78de6eeb06d674c9a4b8176c44d8baaca8cb9f.tar
nixlib-fd78de6eeb06d674c9a4b8176c44d8baaca8cb9f.tar.gz
nixlib-fd78de6eeb06d674c9a4b8176c44d8baaca8cb9f.tar.bz2
nixlib-fd78de6eeb06d674c9a4b8176c44d8baaca8cb9f.tar.lz
nixlib-fd78de6eeb06d674c9a4b8176c44d8baaca8cb9f.tar.xz
nixlib-fd78de6eeb06d674c9a4b8176c44d8baaca8cb9f.tar.zst
nixlib-fd78de6eeb06d674c9a4b8176c44d8baaca8cb9f.zip
Merge pull request #267285 from fricklerhandwerk/code-comment
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/mkshell/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/pkgs/build-support/mkshell/default.nix b/pkgs/build-support/mkshell/default.nix
index 3517e949f67a..5369301ea105 100644
--- a/pkgs/build-support/mkshell/default.nix
+++ b/pkgs/build-support/mkshell/default.nix
@@ -16,6 +16,10 @@
 let
   mergeInputs = name:
     (attrs.${name} or [ ]) ++
+    # 1. get all `{build,nativeBuild,...}Inputs` from the elements of `inputsFrom`
+    # 2. since that is a list of lists, `flatten` that into a regular list
+    # 3. filter out of the result everything that's in `inputsFrom` itself
+    # this leaves actual dependencies of the derivations in `inputsFrom`, but never the derivations themselves
     (lib.subtractLists inputsFrom (lib.flatten (lib.catAttrs name inputsFrom)));
 
   rest = builtins.removeAttrs attrs [