about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2020-06-05 08:10:53 +0100
committerJörg Thalheim <joerg@thalheim.io>2020-06-05 10:41:46 +0100
commitf0396574ab32b2d0b02469e7c2b1446623344f09 (patch)
tree5064c6fd5356a792e9ec64a48c9b97f246c3122b /pkgs/build-support
parentfb6c3cee64826494973fdf4eb362eecac3fd8a11 (diff)
downloadnixlib-f0396574ab32b2d0b02469e7c2b1446623344f09.tar
nixlib-f0396574ab32b2d0b02469e7c2b1446623344f09.tar.gz
nixlib-f0396574ab32b2d0b02469e7c2b1446623344f09.tar.bz2
nixlib-f0396574ab32b2d0b02469e7c2b1446623344f09.tar.lz
nixlib-f0396574ab32b2d0b02469e7c2b1446623344f09.tar.xz
nixlib-f0396574ab32b2d0b02469e7c2b1446623344f09.tar.zst
nixlib-f0396574ab32b2d0b02469e7c2b1446623344f09.zip
buildRustPackage: add documentation on how to create cargo.lock patches
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/rust/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/pkgs/build-support/rust/default.nix b/pkgs/build-support/rust/default.nix
index a6b47930c274..795ce841ffb6 100644
--- a/pkgs/build-support/rust/default.nix
+++ b/pkgs/build-support/rust/default.nix
@@ -130,6 +130,7 @@ stdenv.mkDerivation (args // {
       # give a friendlier error msg.
       if ! [ -e $srcLockfile ]; then
         echo "ERROR: Missing Cargo.lock from src. Expected to find it at: $srcLockfile"
+        echo "Hint: You can use the cargoPatches attribute to add a Cargo.lock manually to the build."
         exit 1
       fi