about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorhacker1024 <hacker1024@users.sourceforge.net>2023-10-21 21:54:21 +1100
committerhacker1024 <hacker1024@users.sourceforge.net>2023-10-21 21:54:21 +1100
commiteeb3936722e6f31ed8e292762be1bc6645cf6c27 (patch)
tree68328d4898460134ec4e63a210f6d01b170c7b12 /pkgs/build-support
parentcd6dcea8068eb6fb656df676fc7577b9b07ec8d3 (diff)
downloadnixlib-eeb3936722e6f31ed8e292762be1bc6645cf6c27.tar
nixlib-eeb3936722e6f31ed8e292762be1bc6645cf6c27.tar.gz
nixlib-eeb3936722e6f31ed8e292762be1bc6645cf6c27.tar.bz2
nixlib-eeb3936722e6f31ed8e292762be1bc6645cf6c27.tar.lz
nixlib-eeb3936722e6f31ed8e292762be1bc6645cf6c27.tar.xz
nixlib-eeb3936722e6f31ed8e292762be1bc6645cf6c27.tar.zst
nixlib-eeb3936722e6f31ed8e292762be1bc6645cf6c27.zip
buildDartApplication: Format with nixpkgs-fmt
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/dart/build-dart-application/default.nix19
1 files changed, 9 insertions, 10 deletions
diff --git a/pkgs/build-support/dart/build-dart-application/default.nix b/pkgs/build-support/dart/build-dart-application/default.nix
index be1fd7277671..b2535123e382 100644
--- a/pkgs/build-support/dart/build-dart-application/default.nix
+++ b/pkgs/build-support/dart/build-dart-application/default.nix
@@ -18,11 +18,10 @@
 , dartEntryPoints ? null
   # Used when wrapping aot, jit, kernel, and js builds.
   # Set to null to disable wrapping.
-, dartRuntimeCommand ?
-    if dartOutputType == "aot-snapshot" then "${dart}/bin/dartaotruntime"
-    else if (dartOutputType == "jit-snapshot" || dartOutputType == "kernel") then "${dart}/bin/dart"
-    else if dartOutputType == "js" then "${nodejs}/bin/node"
-    else null
+, dartRuntimeCommand ? if dartOutputType == "aot-snapshot" then "${dart}/bin/dartaotruntime"
+  else if (dartOutputType == "jit-snapshot" || dartOutputType == "kernel") then "${dart}/bin/dart"
+  else if dartOutputType == "js" then "${nodejs}/bin/node"
+  else null
 
 , pubspecLockFile ? null
 , vendorHash ? ""
@@ -43,15 +42,15 @@ let
   inherit (dartHooks.override { inherit dart; }) dartConfigHook dartBuildHook dartInstallHook;
 in
 assert !(builtins.isString dartOutputType && dartOutputType != "") ->
-  throw "dartOutputType must be a non-empty string";
+throw "dartOutputType must be a non-empty string";
 stdenv.mkDerivation (args // {
   inherit pubGetScript dartCompileCommand dartOutputType dartRuntimeCommand
     dartCompileFlags dartJitFlags;
 
-    dartEntryPoints =
-      if (dartEntryPoints != null)
-      then writeText "entrypoints.json" (builtins.toJSON dartEntryPoints)
-      else null;
+  dartEntryPoints =
+    if (dartEntryPoints != null)
+    then writeText "entrypoints.json" (builtins.toJSON dartEntryPoints)
+    else null;
 
   nativeBuildInputs = (args.nativeBuildInputs or [ ]) ++ [
     dart