about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorhacker1024 <hacker1024@users.sourceforge.net>2024-01-14 17:21:51 +1100
committerhacker1024 <hacker1024@users.sourceforge.net>2024-01-14 17:21:51 +1100
commitee18b58cf4916c5e0a0f80396114ee8786a9f1bb (patch)
tree9efc7f6db769b68ad5844facf55c5041e1117ec5 /pkgs/build-support
parentdd5621df6dcb90122b50da5ec31c411a0de3e538 (diff)
downloadnixlib-ee18b58cf4916c5e0a0f80396114ee8786a9f1bb.tar
nixlib-ee18b58cf4916c5e0a0f80396114ee8786a9f1bb.tar.gz
nixlib-ee18b58cf4916c5e0a0f80396114ee8786a9f1bb.tar.bz2
nixlib-ee18b58cf4916c5e0a0f80396114ee8786a9f1bb.tar.lz
nixlib-ee18b58cf4916c5e0a0f80396114ee8786a9f1bb.tar.xz
nixlib-ee18b58cf4916c5e0a0f80396114ee8786a9f1bb.tar.zst
nixlib-ee18b58cf4916c5e0a0f80396114ee8786a9f1bb.zip
pub2nix: Fix language version regex on Darwin
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/dart/pub2nix/package-config.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/build-support/dart/pub2nix/package-config.nix b/pkgs/build-support/dart/pub2nix/package-config.nix
index 309e51ec84a1..70abb0a76cef 100644
--- a/pkgs/build-support/dart/pub2nix/package-config.nix
+++ b/pkgs/build-support/dart/pub2nix/package-config.nix
@@ -41,7 +41,7 @@ in
     fi
 
     languageConstraint="$(yq -r .environment.sdk "''${packageSources["$package"]}/''${packageRoots["$package"]}/pubspec.yaml")"
-    if [[ "$languageConstraint" =~ ^[[:space:]]*(\^|>=|>|)[[:space:]]*([[:digit:]]+\.[[:digit:]]+)\.[[:digit:]]+.*$ ]]; then
+    if [[ "$languageConstraint" =~ ^[[:space:]]*(\^|>=|>)?[[:space:]]*([[:digit:]]+\.[[:digit:]]+)\.[[:digit:]]+.*$ ]]; then
       languageVersionJson="\"''${BASH_REMATCH[2]}\""
     elif [ "$languageConstraint" = 'any' ]; then
       languageVersionJson='null'