about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2022-10-02 00:04:43 +0000
committerGitHub <noreply@github.com>2022-10-02 00:04:43 +0000
commite879e7d54ee09c8bc8726d40ea2d31e8efdf93b5 (patch)
tree9662884a7112c2a23a1ed52e775896182f967c11 /pkgs/build-support
parentaecf7c7bb9d978330ef40b0179fd25fb7f02d7b4 (diff)
parentae1d03834ebe4881dca31da399e277657ba33779 (diff)
downloadnixlib-e879e7d54ee09c8bc8726d40ea2d31e8efdf93b5.tar
nixlib-e879e7d54ee09c8bc8726d40ea2d31e8efdf93b5.tar.gz
nixlib-e879e7d54ee09c8bc8726d40ea2d31e8efdf93b5.tar.bz2
nixlib-e879e7d54ee09c8bc8726d40ea2d31e8efdf93b5.tar.lz
nixlib-e879e7d54ee09c8bc8726d40ea2d31e8efdf93b5.tar.xz
nixlib-e879e7d54ee09c8bc8726d40ea2d31e8efdf93b5.tar.zst
nixlib-e879e7d54ee09c8bc8726d40ea2d31e8efdf93b5.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/rust/build-rust-package/default.nix4
-rw-r--r--pkgs/build-support/src-only/default.nix2
2 files changed, 1 insertions, 5 deletions
diff --git a/pkgs/build-support/rust/build-rust-package/default.nix b/pkgs/build-support/rust/build-rust-package/default.nix
index 40ae5ece1126..812831c2959c 100644
--- a/pkgs/build-support/rust/build-rust-package/default.nix
+++ b/pkgs/build-support/rust/build-rust-package/default.nix
@@ -72,10 +72,6 @@ let
       sha256 = args.cargoSha256;
     } // depsExtraArgs);
 
-  # If we have a cargoSha256 fixed-output derivation, validate it at build time
-  # against the src fixed-output derivation to check consistency.
-  validateCargoDeps = args ? cargoHash || args ? cargoSha256;
-
   target = rust.toRustTargetSpec stdenv.hostPlatform;
   targetIsJSON = lib.hasSuffix ".json" target;
   useSysroot = targetIsJSON && !__internal_dontAddSysroot;
diff --git a/pkgs/build-support/src-only/default.nix b/pkgs/build-support/src-only/default.nix
index b4e373cd058e..520753e37460 100644
--- a/pkgs/build-support/src-only/default.nix
+++ b/pkgs/build-support/src-only/default.nix
@@ -1,4 +1,4 @@
-{ stdenv }@orig:
+{ stdenv }:
 # srcOnly is a utility builder that only fetches and unpacks the given `src`,
 # maybe pathings it in the process with the optional `patches` and
 # `buildInputs` attributes.