about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2016-11-30 15:14:30 +0100
committerEelco Dolstra <edolstra@gmail.com>2016-11-30 15:14:30 +0100
commite3a873479eee4e19a852011d45b0fb653f6c9e89 (patch)
treeec4b0a04175ec3b76329074c18182230a3ca7074 /pkgs/build-support
parentf26ff0b1bdd6875548edea50efd69698f791ae50 (diff)
downloadnixlib-e3a873479eee4e19a852011d45b0fb653f6c9e89.tar
nixlib-e3a873479eee4e19a852011d45b0fb653f6c9e89.tar.gz
nixlib-e3a873479eee4e19a852011d45b0fb653f6c9e89.tar.bz2
nixlib-e3a873479eee4e19a852011d45b0fb653f6c9e89.tar.lz
nixlib-e3a873479eee4e19a852011d45b0fb653f6c9e89.tar.xz
nixlib-e3a873479eee4e19a852011d45b0fb653f6c9e89.tar.zst
nixlib-e3a873479eee4e19a852011d45b0fb653f6c9e89.zip
Remove fetchMD5warn
Deprecation warnings should not be used in Nixpkgs because they spam
innocent "nix-env -qa" users with (in this case) dozens of messages
that they can't do anything about.

This also reverts commit 2ca883338389b7ab995924a0cab0211993bdf1da.
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/fetchdarcs/default.nix3
-rw-r--r--pkgs/build-support/fetchegg/default.nix3
-rw-r--r--pkgs/build-support/fetchgit/default.nix3
-rw-r--r--pkgs/build-support/fetchhg/default.nix3
-rw-r--r--pkgs/build-support/fetchsvn/default.nix3
-rw-r--r--pkgs/build-support/fetchsvnssh/default.nix3
-rw-r--r--pkgs/build-support/fetchurl/default.nix3
7 files changed, 7 insertions, 14 deletions
diff --git a/pkgs/build-support/fetchdarcs/default.nix b/pkgs/build-support/fetchdarcs/default.nix
index ecec51590b95..3c2e0524eea5 100644
--- a/pkgs/build-support/fetchdarcs/default.nix
+++ b/pkgs/build-support/fetchdarcs/default.nix
@@ -7,8 +7,7 @@ stdenv.mkDerivation {
 
   outputHashAlgo = if sha256 == "" then "md5" else "sha256";
   outputHashMode = "recursive";
-  outputHash = if sha256 == "" then
-    (stdenv.lib.fetchMD5warn "fetchdarcs" url md5) else sha256;
+  outputHash = if sha256 == "" then md5 else sha256;
   
   inherit url rev context;
 }
diff --git a/pkgs/build-support/fetchegg/default.nix b/pkgs/build-support/fetchegg/default.nix
index e82d4d95ac26..3e0d5d566ad7 100644
--- a/pkgs/build-support/fetchegg/default.nix
+++ b/pkgs/build-support/fetchegg/default.nix
@@ -11,8 +11,7 @@ stdenv.mkDerivation {
 
   outputHashAlgo = if sha256 == "" then "md5" else "sha256";
   outputHashMode = "recursive";
-  outputHash = if sha256 == "" then
-    (stdenv.lib.fetchMD5warn "fetchegg" name md5) else sha256;
+  outputHash = if sha256 == "" then md5 else sha256;
 
   inherit version;
 
diff --git a/pkgs/build-support/fetchgit/default.nix b/pkgs/build-support/fetchgit/default.nix
index 982229cf8a5f..e40b460d390a 100644
--- a/pkgs/build-support/fetchgit/default.nix
+++ b/pkgs/build-support/fetchgit/default.nix
@@ -50,8 +50,7 @@ stdenv.mkDerivation {
 
   outputHashAlgo = if sha256 == "" then "md5" else "sha256";
   outputHashMode = "recursive";
-  outputHash = if sha256 == "" then
-    (stdenv.lib.fetchMD5warn "fetchgit" url md5) else sha256;
+  outputHash = if sha256 == "" then md5 else sha256;
 
   inherit url rev leaveDotGit fetchSubmodules deepClone branchName;
 
diff --git a/pkgs/build-support/fetchhg/default.nix b/pkgs/build-support/fetchhg/default.nix
index b30a3556b0fe..79f610166a79 100644
--- a/pkgs/build-support/fetchhg/default.nix
+++ b/pkgs/build-support/fetchhg/default.nix
@@ -15,8 +15,7 @@ stdenv.mkDerivation {
 
   outputHashAlgo = if md5 != null then "md5" else "sha256";
   outputHashMode = "recursive";
-  outputHash = if md5 != null then
-    (stdenv.lib.fetchMD5warn "fetchhg" url md5) else sha256;
+  outputHash = if md5 != null then md5 else sha256;
 
   inherit url rev;
   preferLocalBuild = true;
diff --git a/pkgs/build-support/fetchsvn/default.nix b/pkgs/build-support/fetchsvn/default.nix
index b6f68e21384d..85ec52c4bde0 100644
--- a/pkgs/build-support/fetchsvn/default.nix
+++ b/pkgs/build-support/fetchsvn/default.nix
@@ -29,8 +29,7 @@ stdenv.mkDerivation {
 
   outputHashAlgo = if sha256 == "" then "md5" else "sha256";
   outputHashMode = "recursive";
-  outputHash = if sha256 == "" then
-    (stdenv.lib.fetchMD5warn "fetchsvn" url md5) else sha256;
+  outputHash = if sha256 == "" then md5 else sha256;
   
   inherit url rev sshSupport openssh ignoreExternals;
 
diff --git a/pkgs/build-support/fetchsvnssh/default.nix b/pkgs/build-support/fetchsvnssh/default.nix
index 2d151fad07cb..6c6c03d68732 100644
--- a/pkgs/build-support/fetchsvnssh/default.nix
+++ b/pkgs/build-support/fetchsvnssh/default.nix
@@ -8,8 +8,7 @@ stdenv.mkDerivation {
 
   outputHashAlgo = if sha256 == "" then "md5" else "sha256";
   outputHashMode = "recursive";
-  outputHash = if sha256 == "" then
-    (stdenv.lib.fetchMD5warn "fetchsvnssh" url md5) else sha256;
+  outputHash = if sha256 == "" then md5 else sha256;
   
   sshSubversion = ./sshsubversion.exp;
   
diff --git a/pkgs/build-support/fetchurl/default.nix b/pkgs/build-support/fetchurl/default.nix
index 2cc45ca4bbf2..00f485ce6975 100644
--- a/pkgs/build-support/fetchurl/default.nix
+++ b/pkgs/build-support/fetchurl/default.nix
@@ -112,8 +112,7 @@ if (!hasHash) then throw "Specify hash for fetchurl fixed-output derivation: ${s
   outputHashAlgo = if outputHashAlgo != "" then outputHashAlgo else
       if sha512 != "" then "sha512" else if sha256 != "" then "sha256" else if sha1 != "" then "sha1" else "md5";
   outputHash = if outputHash != "" then outputHash else
-      if sha512 != "" then sha512 else if sha256 != "" then sha256 else if sha1 != "" then sha1 else
-        (stdenv.lib.fetchMD5warn "fetchurl" (builtins.head urls_) md5);
+      if sha512 != "" then sha512 else if sha256 != "" then sha256 else if sha1 != "" then sha1 else md5;
 
   outputHashMode = if (recursiveHash || executable) then "recursive" else "flat";