about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorfigsoda <figsoda@pm.me>2022-09-26 21:53:37 -0400
committerfigsoda <figsoda@pm.me>2022-09-26 21:53:37 -0400
commitdc19b95eff6b56f8dfc4abd75e035d27dd0c1f40 (patch)
tree6697afc16d22236037ed759d8fda047380012826 /pkgs/build-support
parente42908eeaf0cfc2700995a21fc7a08142298a784 (diff)
downloadnixlib-dc19b95eff6b56f8dfc4abd75e035d27dd0c1f40.tar
nixlib-dc19b95eff6b56f8dfc4abd75e035d27dd0c1f40.tar.gz
nixlib-dc19b95eff6b56f8dfc4abd75e035d27dd0c1f40.tar.bz2
nixlib-dc19b95eff6b56f8dfc4abd75e035d27dd0c1f40.tar.lz
nixlib-dc19b95eff6b56f8dfc4abd75e035d27dd0c1f40.tar.xz
nixlib-dc19b95eff6b56f8dfc4abd75e035d27dd0c1f40.tar.zst
nixlib-dc19b95eff6b56f8dfc4abd75e035d27dd0c1f40.zip
rustPlatform.buildRustPackage: remove unused function
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/rust/build-rust-package/default.nix4
1 files changed, 0 insertions, 4 deletions
diff --git a/pkgs/build-support/rust/build-rust-package/default.nix b/pkgs/build-support/rust/build-rust-package/default.nix
index db0d2c53bb1e..84700ff29af0 100644
--- a/pkgs/build-support/rust/build-rust-package/default.nix
+++ b/pkgs/build-support/rust/build-rust-package/default.nix
@@ -72,10 +72,6 @@ let
       sha256 = args.cargoSha256;
     } // depsExtraArgs);
 
-  # If we have a cargoSha256 fixed-output derivation, validate it at build time
-  # against the src fixed-output derivation to check consistency.
-  validateCargoDeps = args ? cargoHash || args ? cargoSha256;
-
   target = rust.toRustTargetSpec stdenv.hostPlatform;
   targetIsJSON = lib.hasSuffix ".json" target;
   useSysroot = targetIsJSON && !__internal_dontAddSysroot;