about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorAlexander Ried <ried@mytum.de>2016-10-29 07:28:47 +0200
committerAlexander Ried <ried@mytum.de>2016-10-29 07:28:52 +0200
commitcc523714a6590973d8cfc3bc3f5b8d2705057762 (patch)
treec95a200775476364ecd1c3ee290764c601f5e9ff /pkgs/build-support
parentc60b3e4bfc94c567db5d68eaaf6c8c1bbb9d43ee (diff)
downloadnixlib-cc523714a6590973d8cfc3bc3f5b8d2705057762.tar
nixlib-cc523714a6590973d8cfc3bc3f5b8d2705057762.tar.gz
nixlib-cc523714a6590973d8cfc3bc3f5b8d2705057762.tar.bz2
nixlib-cc523714a6590973d8cfc3bc3f5b8d2705057762.tar.lz
nixlib-cc523714a6590973d8cfc3bc3f5b8d2705057762.tar.xz
nixlib-cc523714a6590973d8cfc3bc3f5b8d2705057762.tar.zst
nixlib-cc523714a6590973d8cfc3bc3f5b8d2705057762.zip
fetchfile: remove unused file
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/fetchfile/builder.sh11
-rw-r--r--pkgs/build-support/fetchfile/default.nix11
2 files changed, 0 insertions, 22 deletions
diff --git a/pkgs/build-support/fetchfile/builder.sh b/pkgs/build-support/fetchfile/builder.sh
deleted file mode 100644
index b849491fc5ab..000000000000
--- a/pkgs/build-support/fetchfile/builder.sh
+++ /dev/null
@@ -1,11 +0,0 @@
-source $stdenv/setup
-
-echo "copying $pathname into $out..."
-
-cp "$pathname" "$out" || exit 1
-
-actual=$(md5sum -b $out | cut -c1-32)
-if test "$actual" != "$md5"; then
-    echo "hash is $actual, expected $md5"
-    exit 1
-fi
diff --git a/pkgs/build-support/fetchfile/default.nix b/pkgs/build-support/fetchfile/default.nix
deleted file mode 100644
index 685c1e69520a..000000000000
--- a/pkgs/build-support/fetchfile/default.nix
+++ /dev/null
@@ -1,11 +0,0 @@
-{stdenv}: {pathname, md5 ? "", sha256 ? ""}: stdenv.mkDerivation {
-  name = baseNameOf (toString pathname);
-  builder = ./builder.sh;
-  pathname = pathname;
-} // if (sha256 == "") then {
-  md5 = (stdenv.lib.fetchMD5warn "fetchfile" pathname md5);
-  id = md5;
-} else {
-  sha256 = sha256;
-  id = sha256;
-}