about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2016-12-09 11:26:53 +0100
committerMichael Raskin <7c6f434c@mail.ru>2016-12-09 11:26:53 +0100
commitc94e44b0aeca532f6662585eae9bb63c4d4ff73e (patch)
tree1dc86a76169cb71677c8a3f78031b1c1be32d12f /pkgs/build-support
parentff8ec02497412484a54b57ada43e843aec570ba5 (diff)
downloadnixlib-c94e44b0aeca532f6662585eae9bb63c4d4ff73e.tar
nixlib-c94e44b0aeca532f6662585eae9bb63c4d4ff73e.tar.gz
nixlib-c94e44b0aeca532f6662585eae9bb63c4d4ff73e.tar.bz2
nixlib-c94e44b0aeca532f6662585eae9bb63c4d4ff73e.tar.lz
nixlib-c94e44b0aeca532f6662585eae9bb63c4d4ff73e.tar.xz
nixlib-c94e44b0aeca532f6662585eae9bb63c4d4ff73e.tar.zst
nixlib-c94e44b0aeca532f6662585eae9bb63c4d4ff73e.zip
linkFarm: prefer local build
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/trivial-builders.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/build-support/trivial-builders.nix b/pkgs/build-support/trivial-builders.nix
index d6f390ddfb1c..1529869aa331 100644
--- a/pkgs/build-support/trivial-builders.nix
+++ b/pkgs/build-support/trivial-builders.nix
@@ -108,8 +108,9 @@ rec {
 
   # Quickly create a set of symlinks to derivations.
   # entries is a list of attribute sets like { name = "name" ; path = "/nix/store/..."; }
-  linkFarm = name: entries: runCommand name {} ("mkdir -p $out; cd $out; \n" +
-    (lib.concatMapStrings (x: "ln -s '${x.path}' '${x.name}';\n") entries));
+  linkFarm = name: entries: runCommand name { preferLocalBuild = true; }
+    ("mkdir -p $out; cd $out; \n" +
+      (lib.concatMapStrings (x: "ln -s '${x.path}' '${x.name}';\n") entries));
 
 
   # Print an error message if the file with the specified name and