about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2015-04-03 12:46:21 +0200
committerJoachim Fasting <joachifm@fastmail.fm>2015-04-03 13:45:45 +0200
commitba93a75724b9671208d7e48789bc9d71a9da648b (patch)
treed153e2b668f3ab3d1c3b015dcbbc64ef65638519 /pkgs/build-support
parent80283570848734d8473b6434141ce8f4406720e7 (diff)
downloadnixlib-ba93a75724b9671208d7e48789bc9d71a9da648b.tar
nixlib-ba93a75724b9671208d7e48789bc9d71a9da648b.tar.gz
nixlib-ba93a75724b9671208d7e48789bc9d71a9da648b.tar.bz2
nixlib-ba93a75724b9671208d7e48789bc9d71a9da648b.tar.lz
nixlib-ba93a75724b9671208d7e48789bc9d71a9da648b.tar.xz
nixlib-ba93a75724b9671208d7e48789bc9d71a9da648b.tar.zst
nixlib-ba93a75724b9671208d7e48789bc9d71a9da648b.zip
grsecurity module: use types.enum
Also
- set desktop as default system
- make virtualisationSoftware nullOr
- make virtualisationConfig nullOr
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/grsecurity/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/build-support/grsecurity/default.nix b/pkgs/build-support/grsecurity/default.nix
index 7bafd78d76a3..e82792be033a 100644
--- a/pkgs/build-support/grsecurity/default.nix
+++ b/pkgs/build-support/grsecurity/default.nix
@@ -50,14 +50,14 @@ let
         "GRKERNSEC_CONFIG_SERVER y";
 
     grsecVirtCfg =
-      if cfg.config.virtualisationConfig == "none" then
+      if cfg.config.virtualisationConfig == null then
         "GRKERNSEC_CONFIG_VIRT_NONE y"
       else if cfg.config.virtualisationConfig == "host" then
         "GRKERNSEC_CONFIG_VIRT_HOST y"
       else
         "GRKERNSEC_CONFIG_VIRT_GUEST y";
 
-    grsecHwvirtCfg = if cfg.config.virtualisationConfig == "none" then "" else
+    grsecHwvirtCfg = if cfg.config.virtualisationConfig == null then "" else
       if cfg.config.hardwareVirtualisation == true then
         "GRKERNSEC_CONFIG_VIRT_EPT y"
       else
@@ -66,7 +66,7 @@ let
     grsecVirtswCfg =
       let virtCfg = opt: "GRKERNSEC_CONFIG_VIRT_"+opt+" y";
       in
-        if cfg.config.virtualisationConfig == "none" then ""
+        if cfg.config.virtualisationConfig == null then ""
         else if cfg.config.virtualisationSoftware == "xen"    then virtCfg "XEN"
         else if cfg.config.virtualisationSoftware == "kvm"    then virtCfg "KVM"
         else if cfg.config.virtualisationSoftware == "vmware" then virtCfg "VMWARE"