about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2019-02-23 21:12:16 +0100
committerProfpatsch <mail@profpatsch.de>2019-02-23 23:28:26 +0100
commitb64d25c44782027414509460c1900646dee57db1 (patch)
tree368ab0769d5e664b7b63a16ea788d52ef638cb9a /pkgs/build-support
parentfae3c6fb9efb4a742d706a18a82087870720f3e0 (diff)
downloadnixlib-b64d25c44782027414509460c1900646dee57db1.tar
nixlib-b64d25c44782027414509460c1900646dee57db1.tar.gz
nixlib-b64d25c44782027414509460c1900646dee57db1.tar.bz2
nixlib-b64d25c44782027414509460c1900646dee57db1.tar.lz
nixlib-b64d25c44782027414509460c1900646dee57db1.tar.xz
nixlib-b64d25c44782027414509460c1900646dee57db1.tar.zst
nixlib-b64d25c44782027414509460c1900646dee57db1.zip
skawarePackages.execline: wrap execlineb with tools
The execlineb program is the launcher (and lexer) of execline scripts.
So it makes a lot of sense to have all the small tools in scope by
default.
We append to the end of PATH so that they can be easily overwritten by
the user.

Co-authored-by: Alyssa Ross <hi@alyssa.is>
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/skaware/build-skaware-package.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/build-support/skaware/build-skaware-package.nix b/pkgs/build-support/skaware/build-skaware-package.nix
index 51921fdfbdc7..5ae8985e3abe 100644
--- a/pkgs/build-support/skaware/build-skaware-package.nix
+++ b/pkgs/build-support/skaware/build-skaware-package.nix
@@ -19,6 +19,10 @@ in {
   # mostly for moving and deleting files from the build directory
   # : lines
 , postInstall
+  # packages with setup hooks that should be run
+  # (see definition of `makeSetupHook`)
+  # : list drv
+, setupHooks ? []
   # : list Maintainer
 , maintainers ? []
 
@@ -82,6 +86,8 @@ in stdenv.mkDerivation {
   dontDisableStatic = true;
   enableParallelBuilding = true;
 
+  nativeBuildInputs = setupHooks;
+
   configureFlags = configureFlags ++ [
     "--enable-absolute-paths"
     (if stdenv.isDarwin