about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-04-24 14:46:01 -0500
committerGitHub <noreply@github.com>2018-04-24 14:46:01 -0500
commitab92a474a9e38c5edb8ece0dd6774d966cd4557d (patch)
treea29343e568c590c407cfba517eafb6c24ba4d3d2 /pkgs/build-support
parent78d9bffc0a69fcf7acf40674211b395908aa39db (diff)
parent31ef995e37ad4291afdaebb2c6480280fd058858 (diff)
downloadnixlib-ab92a474a9e38c5edb8ece0dd6774d966cd4557d.tar
nixlib-ab92a474a9e38c5edb8ece0dd6774d966cd4557d.tar.gz
nixlib-ab92a474a9e38c5edb8ece0dd6774d966cd4557d.tar.bz2
nixlib-ab92a474a9e38c5edb8ece0dd6774d966cd4557d.tar.lz
nixlib-ab92a474a9e38c5edb8ece0dd6774d966cd4557d.tar.xz
nixlib-ab92a474a9e38c5edb8ece0dd6774d966cd4557d.tar.zst
nixlib-ab92a474a9e38c5edb8ece0dd6774d966cd4557d.zip
Merge pull request #38822 from matthewbauer/netbsd
Introducing NetBSD userland
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/fetchcvs/builder.sh5
-rw-r--r--pkgs/build-support/fetchcvs/default.nix6
2 files changed, 8 insertions, 3 deletions
diff --git a/pkgs/build-support/fetchcvs/builder.sh b/pkgs/build-support/fetchcvs/builder.sh
index 6ee594b33b27..0975c3478820 100644
--- a/pkgs/build-support/fetchcvs/builder.sh
+++ b/pkgs/build-support/fetchcvs/builder.sh
@@ -1,5 +1,10 @@
 source $stdenv/setup
 
+(echo '#!/usr/bin/env sh'; \
+ echo 'ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no "$@"') > ssh
+chmod +x ssh
+export CVS_RSH=$PWD/ssh
+
 # creating the export drictory and checking out there only to be able to
 # move the content without the root directory into $out ...
 # cvs -f -d "$url" export $tag -d "$out" "$module"
diff --git a/pkgs/build-support/fetchcvs/default.nix b/pkgs/build-support/fetchcvs/default.nix
index 9d9deb3f629e..1f7947d4d452 100644
--- a/pkgs/build-support/fetchcvs/default.nix
+++ b/pkgs/build-support/fetchcvs/default.nix
@@ -3,18 +3,18 @@
 # tag="<tagname>" (get version by tag name)
 # If you don't specify neither one date="NOW" will be used (get latest)
 
-{stdenvNoCC, cvs}:
+{stdenvNoCC, cvs, openssh}:
 
 {cvsRoot, module, tag ? null, date ? null, sha256}:
 
 stdenvNoCC.mkDerivation {
   name = "cvs-export";
   builder = ./builder.sh;
-  nativeBuildInputs = [cvs];
+  nativeBuildInputs = [cvs openssh];
 
   outputHashAlgo = "sha256";
   outputHashMode = "recursive";
   outputHash = sha256;
-  
+
   inherit cvsRoot module sha256 tag date;
 }