about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-01 12:41:28 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-01 13:12:45 +0200
commita40f68ddfb81322bd8651a1b150c3e5f6d3df995 (patch)
treec01a0ca7c141c800ba6b454c0b8624469aac8345 /pkgs/build-support
parent7e816e90580c85de72b0ab3af04e258796ad4e1d (diff)
downloadnixlib-a40f68ddfb81322bd8651a1b150c3e5f6d3df995.tar
nixlib-a40f68ddfb81322bd8651a1b150c3e5f6d3df995.tar.gz
nixlib-a40f68ddfb81322bd8651a1b150c3e5f6d3df995.tar.bz2
nixlib-a40f68ddfb81322bd8651a1b150c3e5f6d3df995.tar.lz
nixlib-a40f68ddfb81322bd8651a1b150c3e5f6d3df995.tar.xz
nixlib-a40f68ddfb81322bd8651a1b150c3e5f6d3df995.tar.zst
nixlib-a40f68ddfb81322bd8651a1b150c3e5f6d3df995.zip
Remove unused file
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/checker/default.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/pkgs/build-support/checker/default.nix b/pkgs/build-support/checker/default.nix
deleted file mode 100644
index 66f8c45e37bc..000000000000
--- a/pkgs/build-support/checker/default.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-#
-#  Checks that all set options are described.
-#
-options: configuration:
-with builtins;
-let lib=(import ../../lib); in
-with lib;
-
-let 
-  findInList = p: list: default:
-       if list == [] then default else
-       if (p (head list)) then (head list) else
-       findInList p (tail list) default;
-  
-
-  checkAttrInclusion = s: a: b:
-	(
-	if ! isAttrs b then s else
-	if (lib.attrByPath ["_type"] "" b) == "option" then "" else
-	findInList (x : x != "") 
-		( map (x: if (x == "servicesProposal") # this attr will be checked at another place ( -> upstart-jobs/default.nix )
-                       then ""
-                       else checkAttrInclusion 
-			(s + "." + x) 
-			(builtins.getAttr x a)
-			(lib.attrByPath [x] null b)) 
-		(attrNames a)) ""
-	);
-in 	
-	checkAttrInclusion "" configuration options
-