about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-07-04 23:36:17 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-07-05 00:17:04 +0200
commit9efe759dd8fb8fd85368483923a77f832b8805c6 (patch)
tree37f11af3d0edc39372d7fcfbb888b5ad355a452a /pkgs/build-support
parent2321f2d55c6742fae0830142023816439ad83690 (diff)
downloadnixlib-9efe759dd8fb8fd85368483923a77f832b8805c6.tar
nixlib-9efe759dd8fb8fd85368483923a77f832b8805c6.tar.gz
nixlib-9efe759dd8fb8fd85368483923a77f832b8805c6.tar.bz2
nixlib-9efe759dd8fb8fd85368483923a77f832b8805c6.tar.lz
nixlib-9efe759dd8fb8fd85368483923a77f832b8805c6.tar.xz
nixlib-9efe759dd8fb8fd85368483923a77f832b8805c6.tar.zst
nixlib-9efe759dd8fb8fd85368483923a77f832b8805c6.zip
VM builds: Increase the default memory size to 512 MB
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/vm/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/build-support/vm/default.nix b/pkgs/build-support/vm/default.nix
index eb585f2bc501..8065e5fa9109 100644
--- a/pkgs/build-support/vm/default.nix
+++ b/pkgs/build-support/vm/default.nix
@@ -324,7 +324,7 @@ rec {
      `preVM' can optionally contain a shell command to be evaluated
      *before* the VM is started (i.e., on the host).  The attribute
      `memSize' specifies the memory size of the VM in megabytes,
-     defaulting to 256.  The attribute `diskImage' can optionally
+     defaulting to 512.  The attribute `diskImage' can optionally
      specify a file system image to be attached to /dev/sda.  (Note
      that currently we expect the image to contain a filesystem, not a
      full disk image with a partition table etc.)
@@ -339,7 +339,7 @@ rec {
     args = ["-e" (vmRunCommand qemuCommandLinux)];
     origArgs = attrs.args;
     origBuilder = attrs.builder;
-    QEMU_OPTS = "-m ${toString (if attrs ? memSize then attrs.memSize else 256)}";
+    QEMU_OPTS = "-m ${toString (if attrs ? memSize then attrs.memSize else 512)}";
   });