about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-07-19 08:06:14 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-07-19 08:09:29 +0200
commit9a80550cc461fe364adae86478bc51dce564e596 (patch)
treea8b468f2ce6bdee6b345c3a7b7bc412b1efd583f /pkgs/build-support
parent7acbdcd02b52fd99a826b16c832888dbff64088f (diff)
parent4efbe9620569c977cab38609de34e00d81c819fd (diff)
downloadnixlib-9a80550cc461fe364adae86478bc51dce564e596.tar
nixlib-9a80550cc461fe364adae86478bc51dce564e596.tar.gz
nixlib-9a80550cc461fe364adae86478bc51dce564e596.tar.bz2
nixlib-9a80550cc461fe364adae86478bc51dce564e596.tar.lz
nixlib-9a80550cc461fe364adae86478bc51dce564e596.tar.xz
nixlib-9a80550cc461fe364adae86478bc51dce564e596.tar.zst
nixlib-9a80550cc461fe364adae86478bc51dce564e596.zip
Merge branch 'staging', discussion #8844
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/cc-wrapper/default.nix3
-rw-r--r--pkgs/build-support/cc-wrapper/setup-hook-stdinc.sh44
-rw-r--r--pkgs/build-support/cc-wrapper/setup-hook.sh2
-rw-r--r--pkgs/build-support/trivial-builders.nix1
4 files changed, 3 insertions, 47 deletions
diff --git a/pkgs/build-support/cc-wrapper/default.nix b/pkgs/build-support/cc-wrapper/default.nix
index c8af548a2ca4..ec024c72481d 100644
--- a/pkgs/build-support/cc-wrapper/default.nix
+++ b/pkgs/build-support/cc-wrapper/default.nix
@@ -9,7 +9,6 @@
 , cc ? null, libc ? null, binutils ? null, coreutils ? null, shell ? stdenv.shell
 , zlib ? null, extraPackages ? []
 , dyld ? null # TODO: should this be a setup-hook on dyld?
-, setupHook ? ./setup-hook.sh
 , isGNU ? false, isClang ? false
 }:
 
@@ -227,7 +226,7 @@ stdenv.mkDerivation {
     ''
 
     + ''
-      substituteAll ${setupHook} $out/nix-support/setup-hook.tmp
+      substituteAll ${./setup-hook.sh} $out/nix-support/setup-hook.tmp
       cat $out/nix-support/setup-hook.tmp >> $out/nix-support/setup-hook
       rm $out/nix-support/setup-hook.tmp
 
diff --git a/pkgs/build-support/cc-wrapper/setup-hook-stdinc.sh b/pkgs/build-support/cc-wrapper/setup-hook-stdinc.sh
deleted file mode 100644
index 22e778b06904..000000000000
--- a/pkgs/build-support/cc-wrapper/setup-hook-stdinc.sh
+++ /dev/null
@@ -1,44 +0,0 @@
-# This is an alternate setup hook for gcc-wrapper that uses the -I flag to
-# add include search paths instead of -isystem. We need this for some packages
-# because -isystem can change the search order specified by prior -I flags.
-# Changing the search order can point gcc to the wrong package's headers.
-# The -I flag will never change the order of prior flags.
-
-export NIX_CC=@out@
-
-addCVars () {
-    if [ -d $1/include ]; then
-        export NIX_CFLAGS_COMPILE+=" -I $1/include"
-    fi
-
-    if [ -d $1/lib64 -a ! -L $1/lib64 ]; then
-        export NIX_LDFLAGS+=" -L$1/lib64"
-    fi
-
-    if [ -d $1/lib ]; then
-        export NIX_LDFLAGS+=" -L$1/lib"
-    fi
-}
-
-envHooks+=(addCVars)
-
-# Note: these come *after* $out in the PATH (see setup.sh).
-
-if [ -n "@gcc@" ]; then
-    addToSearchPath PATH @gcc@/bin
-fi
-
-if [ -n "@binutils@" ]; then
-    addToSearchPath PATH @binutils@/bin
-fi
-
-if [ -n "@libc@" ]; then
-    addToSearchPath PATH @libc@/bin
-fi
-
-if [ -n "@coreutils@" ]; then
-    addToSearchPath PATH @coreutils@/bin
-fi
-
-export CC=gcc
-export CXX=g++
diff --git a/pkgs/build-support/cc-wrapper/setup-hook.sh b/pkgs/build-support/cc-wrapper/setup-hook.sh
index 648afda6ebb9..3d0b2fdfe8ae 100644
--- a/pkgs/build-support/cc-wrapper/setup-hook.sh
+++ b/pkgs/build-support/cc-wrapper/setup-hook.sh
@@ -2,7 +2,7 @@ export NIX_CC=@out@
 
 addCVars () {
     if [ -d $1/include ]; then
-        export NIX_CFLAGS_COMPILE+=" -isystem $1/include"
+        export NIX_CFLAGS_COMPILE+=" ${ccIncludeFlag:--isystem} $1/include"
     fi
 
     if [ -d $1/lib64 -a ! -L $1/lib64 ]; then
diff --git a/pkgs/build-support/trivial-builders.nix b/pkgs/build-support/trivial-builders.nix
index d9eeaa31359d..9203425b20ae 100644
--- a/pkgs/build-support/trivial-builders.nix
+++ b/pkgs/build-support/trivial-builders.nix
@@ -23,6 +23,7 @@ rec {
         passAsFile = [ "text" ];
         # Pointless to do this on a remote machine.
         preferLocalBuild = true;
+        allowSubstitutes = false;
       }
       ''
         n=$out${destination}