about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorBrian McKenna <bmckenna@atlassian.com>2016-02-16 21:55:25 +1100
committerBrian McKenna <bmckenna@atlassian.com>2016-02-17 07:28:26 +1100
commit8b644c5826f9e0c62f84fa7844e369fca9a41a96 (patch)
tree37b9c532c18c33efea541ed2fa0c60e4bb21ee59 /pkgs/build-support
parent7fcce2a9f09f45de51be85da7c62b109af95d753 (diff)
downloadnixlib-8b644c5826f9e0c62f84fa7844e369fca9a41a96.tar
nixlib-8b644c5826f9e0c62f84fa7844e369fca9a41a96.tar.gz
nixlib-8b644c5826f9e0c62f84fa7844e369fca9a41a96.tar.bz2
nixlib-8b644c5826f9e0c62f84fa7844e369fca9a41a96.tar.lz
nixlib-8b644c5826f9e0c62f84fa7844e369fca9a41a96.tar.xz
nixlib-8b644c5826f9e0c62f84fa7844e369fca9a41a96.tar.zst
nixlib-8b644c5826f9e0c62f84fa7844e369fca9a41a96.zip
rust: fix prePatch phase fail when sourceRoot set
We want to go up more than a single directory if we're in a nested one.
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/rust/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/build-support/rust/default.nix b/pkgs/build-support/rust/default.nix
index e0d451417780..79e4366eebe1 100644
--- a/pkgs/build-support/rust/default.nix
+++ b/pkgs/build-support/rust/default.nix
@@ -75,7 +75,7 @@ in stdenv.mkDerivation (args // {
     (
         set -euo pipefail
 
-        cd ../deps/registry/src/*
+        cd $NIX_BUILD_TOP/deps/registry/src/*
 
         for script in $patchRegistryDeps/*; do
           # Run in a subshell so that directory changes and shell options don't