about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2013-12-16 21:20:49 +0100
committerPeter Simons <simons@cryp.to>2013-12-16 21:20:49 +0100
commit8b11fb8fcbb6d03680edfaaef32463693bcb04b9 (patch)
tree31126966312ea6d0756ba3d368efc7383d2c8c31 /pkgs/build-support
parent45e8de9a7d457e5202d17fcbf4a6c58afa3388e8 (diff)
downloadnixlib-8b11fb8fcbb6d03680edfaaef32463693bcb04b9.tar
nixlib-8b11fb8fcbb6d03680edfaaef32463693bcb04b9.tar.gz
nixlib-8b11fb8fcbb6d03680edfaaef32463693bcb04b9.tar.bz2
nixlib-8b11fb8fcbb6d03680edfaaef32463693bcb04b9.tar.lz
nixlib-8b11fb8fcbb6d03680edfaaef32463693bcb04b9.tar.xz
nixlib-8b11fb8fcbb6d03680edfaaef32463693bcb04b9.tar.zst
nixlib-8b11fb8fcbb6d03680edfaaef32463693bcb04b9.zip
pkgs/build-support/cabal: clean up the code that sets rpath for shared executables
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/cabal/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/build-support/cabal/default.nix b/pkgs/build-support/cabal/default.nix
index d99faf41f88d..8984feac167b 100644
--- a/pkgs/build-support/cabal/default.nix
+++ b/pkgs/build-support/cabal/default.nix
@@ -156,7 +156,7 @@ assert !enableStaticLibraries -> versionOlder "7.7" ghc.version;
               (optional (versionOlder "7" ghc.version) (enableFeature self.enableStaticLibraries "library-vanilla"))
               (optional (versionOlder "7.4" ghc.version) (enableFeature self.enableSharedExecutables "executable-dynamic"))
               (optional (versionOlder "7" ghc.version) (enableFeature self.doCheck "tests"))
-            ] ++ optional self.enableSharedExecutables "--ghc-option=-optl=-Wl,-rpath=$ORIGIN/../lib/${ghc.ghc.name}/${self.pname}-${self.version}";
+            ];
 
             # GHC needs the locale configured during the Haddock phase.
             LANG = "en_US.UTF-8";
@@ -187,6 +187,10 @@ assert !enableStaticLibraries -> versionOlder "7.7" ghc.version;
                 done
               done
 
+              ${optionalString self.enableSharedExecutables ''
+                configureFlags+=" --ghc-option=-optl=-Wl,-rpath=$out/lib/${ghc.ghc.name}/${self.pname}-${self.version}";
+              ''}
+
               echo "configure flags: $extraConfigureFlags $configureFlags"
               ./Setup configure --verbose --prefix="$out" --libdir='$prefix/lib/$compiler' --libsubdir='$pkgid' $extraConfigureFlags $configureFlags