about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorJohn Ericson <git@JohnEricson.me>2019-03-29 16:11:22 -0400
committerGitHub <noreply@github.com>2019-03-29 16:11:22 -0400
commit842b14ba98e037ff954eefe7f2bb60b7707735e9 (patch)
tree6c8ef00653e664843c343b6b02d1df3e48be0311 /pkgs/build-support
parentb46e9ad84b96ffce579ae5132f311b28b6d78506 (diff)
parentc17cf32a3724bf6c23cb3146acb639c414c8edd8 (diff)
downloadnixlib-842b14ba98e037ff954eefe7f2bb60b7707735e9.tar
nixlib-842b14ba98e037ff954eefe7f2bb60b7707735e9.tar.gz
nixlib-842b14ba98e037ff954eefe7f2bb60b7707735e9.tar.bz2
nixlib-842b14ba98e037ff954eefe7f2bb60b7707735e9.tar.lz
nixlib-842b14ba98e037ff954eefe7f2bb60b7707735e9.tar.xz
nixlib-842b14ba98e037ff954eefe7f2bb60b7707735e9.tar.zst
nixlib-842b14ba98e037ff954eefe7f2bb60b7707735e9.zip
Merge pull request #58330 from AerialX/msp430
TI MSP430 cross compiling
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/bintools-wrapper/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/pkgs/build-support/bintools-wrapper/default.nix b/pkgs/build-support/bintools-wrapper/default.nix
index 142f5255caad..72327d2bb671 100644
--- a/pkgs/build-support/bintools-wrapper/default.nix
+++ b/pkgs/build-support/bintools-wrapper/default.nix
@@ -186,6 +186,7 @@ stdenv.mkDerivation {
         }.${targetPlatform.parsed.cpu.name}
       else if targetPlatform.isPower then if targetPlatform.isBigEndian then "ppc" else "lppc"
       else if targetPlatform.isSparc then "sparc"
+      else if targetPlatform.isMsp430 then "msp430"
       else if targetPlatform.isAvr then "avr"
       else if targetPlatform.isAlpha then "alpha"
       else throw "unknown emulation for platform: " + targetPlatform.config;