about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2008-06-18 15:09:13 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2008-06-18 15:09:13 +0000
commit7bf0c5ba012198ca529de76c215f5ef5ea474cb4 (patch)
tree07e7d78b8c088706e6d563e7583d287904a32a3c /pkgs/build-support
parentaab9aee56ef90e2e75c70e2b7e27445b559e0cbc (diff)
downloadnixlib-7bf0c5ba012198ca529de76c215f5ef5ea474cb4.tar
nixlib-7bf0c5ba012198ca529de76c215f5ef5ea474cb4.tar.gz
nixlib-7bf0c5ba012198ca529de76c215f5ef5ea474cb4.tar.bz2
nixlib-7bf0c5ba012198ca529de76c215f5ef5ea474cb4.tar.lz
nixlib-7bf0c5ba012198ca529de76c215f5ef5ea474cb4.tar.xz
nixlib-7bf0c5ba012198ca529de76c215f5ef5ea474cb4.tar.zst
nixlib-7bf0c5ba012198ca529de76c215f5ef5ea474cb4.zip
* Folded the Cygwin, powerpc-darwin and FreeBSD stdenv into the "native"
  stdenv.

svn path=/nixpkgs/trunk/; revision=12147
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/gcc-wrapper/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/build-support/gcc-wrapper/default.nix b/pkgs/build-support/gcc-wrapper/default.nix
index 6e67bbf74e6b..1cd84d775472 100644
--- a/pkgs/build-support/gcc-wrapper/default.nix
+++ b/pkgs/build-support/gcc-wrapper/default.nix
@@ -21,7 +21,10 @@ stdenv.mkDerivation {
   utils = ./utils.sh;
   addFlags = ./add-flags;
   
-  inherit nativeTools nativeLibc nativePrefix gcc libc binutils;
+  inherit nativeTools nativeLibc nativePrefix gcc;
+  libc = if nativeLibc then null else libc;
+  binutils = if nativeTools then null else binutils;
+  
   name = if name == "" then gcc.name else name;
   langC = if nativeTools then true else gcc.langC;
   langCC = if nativeTools then true else gcc.langCC;