about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorYury G. Kudryashov <urkud.urkud@gmail.com>2010-05-03 09:13:17 +0000
committerYury G. Kudryashov <urkud.urkud@gmail.com>2010-05-03 09:13:17 +0000
commit796ffd9f71b94d6f78cadf4c3214778ec181dd67 (patch)
treef1dc1eac7b915da621a6ec74d3d0fad54a799cf1 /pkgs/build-support
parent2d9ba975e788a134c254e1967758f85f9db4e876 (diff)
downloadnixlib-796ffd9f71b94d6f78cadf4c3214778ec181dd67.tar
nixlib-796ffd9f71b94d6f78cadf4c3214778ec181dd67.tar.gz
nixlib-796ffd9f71b94d6f78cadf4c3214778ec181dd67.tar.bz2
nixlib-796ffd9f71b94d6f78cadf4c3214778ec181dd67.tar.lz
nixlib-796ffd9f71b94d6f78cadf4c3214778ec181dd67.tar.xz
nixlib-796ffd9f71b94d6f78cadf4c3214778ec181dd67.tar.zst
nixlib-796ffd9f71b94d6f78cadf4c3214778ec181dd67.zip
Move "fetchurl restricted" code to requireFile.
This reverts r21474 and r21467.
Also migrate wtk (r21472) to new API.

svn path=/nixpkgs/trunk/; revision=21575
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/fetchurl/default.nix68
-rw-r--r--pkgs/build-support/trivial-builders.nix30
2 files changed, 51 insertions, 47 deletions
diff --git a/pkgs/build-support/fetchurl/default.nix b/pkgs/build-support/fetchurl/default.nix
index 1ee4946c8564..1ba9124027d4 100644
--- a/pkgs/build-support/fetchurl/default.nix
+++ b/pkgs/build-support/fetchurl/default.nix
@@ -1,4 +1,4 @@
-{stdenv, curl, writeScript}: # Note that `curl' may be `null', in case of the native stdenv.
+{stdenv, curl}: # Note that `curl' may be `null', in case of the native stdenv.
 
 let
 
@@ -23,7 +23,7 @@ let
     else [] /* backwards compatibility */;
 
 in
-
+      
 { # URL to fetch.
   url ? ""
 
@@ -45,12 +45,6 @@ in
 , # If set, don't download the file, but write a list of all possible
   # URLs (resulting from resolving mirror:// URLs) to $out.
   showURLs ? false
-
-, # If set, down't download file but tell user how to download it.
-  restricted ? false
-
-, # Used only if restricted. Should contain instructions how to fetch the file.
-  message ? ""
 }:
 
 assert urls != [] -> url == "";
@@ -62,55 +56,34 @@ assert showURLs || (outputHash != "" && outputHashAlgo != "")
 let
 
   urls_ = if urls != [] then urls else [url];
-  name_ = if showURLs then "urls"
-    else if name != "" then name
-    else baseNameOf (toString (builtins.head urls_));
-  hashAlgo_ = if outputHashAlgo != "" then outputHashAlgo else
-    if sha256 != "" then "sha256" else if sha1 != "" then "sha1" else "md5";
-  hash_ = if outputHash != "" then outputHash else
-    if sha256 != "" then sha256 else if sha1 != "" then sha1 else md5;
-in
 
-stdenv.mkDerivation ({
-  name = name_;
-  outputHashAlgo = hashAlgo_;
-  outputHash = hash_;
-  urls = urls_;
-
-  # Compatibility with Nix <= 0.7.
-  id = md5;
+in
 
-  inherit showURLs mirrorsFile;
-}
-// (if (!showURLs && restricted) then rec {
-  builder = writeScript "restrict-message" ''
-source ${stdenv}/setup
-cat <<_EOF_
-${message_}
-_EOF_
-  '';
-  message_ = if message != "" then message else ''
-  You have to download ${name_} from ${stdenv.lib.concatStringsSep " " urls_} yourself,
-  and add it to the store using either
-    nix-store --add-fixed ${hashAlgo_} ${name_}
-  or
-    ${if hashAlgo_ != "sha256" then "NIX_HASH_ALGO=${hashAlgo_} " else
-      ""}nix-prefetch-url file://path/to/${name_}
-  '';
-}
-else {
+stdenv.mkDerivation {
+  name =
+    if showURLs then "urls"
+    else if name != "" then name
+    else baseNameOf (toString (builtins.head urls_));
+    
   builder = ./builder.sh;
-
+  
   buildInputs = [curl];
 
+  urls = urls_;
 
   # If set, prefer the content-addressable mirrors
   # (http://nixos.org/tarballs) over the original URLs.
   preferHashedMirrors = true;
 
+  # Compatibility with Nix <= 0.7.
+  id = md5;
 
   # New-style output content requirements.
-
+  outputHashAlgo = if outputHashAlgo != "" then outputHashAlgo else
+      if sha256 != "" then "sha256" else if sha1 != "" then "sha1" else "md5";
+  outputHash = if outputHash != "" then outputHash else
+      if sha256 != "" then sha256 else if sha1 != "" then sha1 else md5;
+  
   impureEnvVars = [
     # We borrow these environment variables from the caller to allow
     # easy proxy configuration.  This is impure, but a fixed-output
@@ -122,5 +95,6 @@ else {
     # command-line.
     "NIX_HASHED_MIRRORS"
   ] ++ (map (site: "NIX_MIRRORS_${site}") sites);
-})
-)
+
+  inherit showURLs mirrorsFile;
+}
diff --git a/pkgs/build-support/trivial-builders.nix b/pkgs/build-support/trivial-builders.nix
index 25ae340629b1..992e28476f06 100644
--- a/pkgs/build-support/trivial-builders.nix
+++ b/pkgs/build-support/trivial-builders.nix
@@ -73,6 +73,36 @@ rec {
   linkFarm = name: entries: runCommand name {} ("mkdir -p $out; cd $out; \n" +
     (stdenv.lib.concatMapStrings (x: "ln -s '${x.path}' '${x.name}';\n") entries));
 
+  # Require file
+  requireFile = {name, sha256, url ? null, message ? null} :
+    assert (message != null) || (url != null);
+    let msg =
+      if message != null then message
+      else ''
+        Unfortunately, we may not download file ${name} automatically.
+        Please, go to ${url}, download it yourself, and add it to the Nix store
+        using either
+          nix-store --add-fixed sha256 ${name}
+        or
+          nix-prefetch-url file://path/to/${name}
+      '';
+    in
+    stdenv.mkDerivation {
+      inherit name;
+      outputHashAlgo = "sha256";
+      outputHash = sha256;
+      builder = writeScript "restrict-message" ''
+source ${stdenv}/setup
+cat <<_EOF_
+
+***
+${msg}
+***
+
+_EOF_
+      '';
+    };
+
   # Search in the environment if the same program exists with a set uid or
   # set gid bit.  If it exists, run the first program found, otherwise run
   # the default binary.