about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-09-15 12:16:44 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-09-15 12:16:49 -0700
commit773b4deb7c5c6300f23f2ec2db4751e40f6520fa (patch)
tree45e1caaa95b76b129efe46e8c048be03c91f3baf /pkgs/build-support
parent316a09377d12b29764b5daf51e0df8986a5fe175 (diff)
parenta6f6c0eeeb45ad122022366724e396955f0f775b (diff)
downloadnixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar.gz
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar.bz2
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar.lz
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar.xz
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.tar.zst
nixlib-773b4deb7c5c6300f23f2ec2db4751e40f6520fa.zip
Merge commit 'a6f6c0e' into master.upstream
This is a partial merge of staging where we have up to date binaries for
all packages.
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/builder-defs/builder-defs.nix2
-rw-r--r--pkgs/build-support/cc-wrapper/default.nix2
-rw-r--r--pkgs/build-support/setup-hooks/patch-shebangs.sh2
3 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/build-support/builder-defs/builder-defs.nix b/pkgs/build-support/builder-defs/builder-defs.nix
index d4e7f703af9b..551ed9ea57e8 100644
--- a/pkgs/build-support/builder-defs/builder-defs.nix
+++ b/pkgs/build-support/builder-defs/builder-defs.nix
@@ -569,7 +569,7 @@ let inherit (builtins) head tail trace; in
      # Interpreters that are already in the store are left untouched.
          echo "patching script interpreter paths"
          local f
-         for f in $(find "${dir}" -xtype f -perm /0100); do
+         for f in $(find "${dir}" -xtype f -perm -0100); do
              local oldPath=$(sed -ne '1 s,^#![ ]*\([^ ]*\).*$,\1,p' "$f")
              if test -n "$oldPath" -a "''${oldPath:0:''${#NIX_STORE}}" != "$NIX_STORE"; then
                  local newPath=$(type -P $(basename $oldPath) || true)
diff --git a/pkgs/build-support/cc-wrapper/default.nix b/pkgs/build-support/cc-wrapper/default.nix
index 8965fc6bef0c..9822b1a026a1 100644
--- a/pkgs/build-support/cc-wrapper/default.nix
+++ b/pkgs/build-support/cc-wrapper/default.nix
@@ -244,7 +244,7 @@ stdenv.mkDerivation {
        if stdenv.isArm then "ld-linux*.so.3" else
        if stdenv.system == "powerpc-linux" then "ld.so.1" else
        if stdenv.system == "mips64el-linux" then "ld.so.1" else
-       if stdenv.system == "x86_64-darwin" then "${dyld}/lib/dyld" else
+       if stdenv.system == "x86_64-darwin" then "/usr/lib/dyld" else
        abort "Don't know the name of the dynamic linker for this platform.")
     else "";
 
diff --git a/pkgs/build-support/setup-hooks/patch-shebangs.sh b/pkgs/build-support/setup-hooks/patch-shebangs.sh
index 44ebad0d593b..152755992f68 100644
--- a/pkgs/build-support/setup-hooks/patch-shebangs.sh
+++ b/pkgs/build-support/setup-hooks/patch-shebangs.sh
@@ -18,7 +18,7 @@ patchShebangs() {
     local oldInterpreterLine
     local newInterpreterLine
 
-    find "$dir" -type f -perm /0100 | while read f; do
+    find "$dir" -type f -perm -0100 | while read f; do
         if [ "$(head -1 "$f" | head -c +2)" != '#!' ]; then
             # missing shebang => not a script
             continue