about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorDaiderd Jordan <daiderd@gmail.com>2018-04-23 21:29:08 +0200
committerGitHub <noreply@github.com>2018-04-23 21:29:08 +0200
commit65e92d19d286ccce3ee7bf3d74609ed7224dc66f (patch)
tree7052e99d857321ab2381ce69b2c0429681c8d83d /pkgs/build-support
parent70de58343f302d0589826cd1e7aa1873e1a6a9bd (diff)
parentdc53518dc3efb0a7152e101a75b8c3a16d44feb0 (diff)
downloadnixlib-65e92d19d286ccce3ee7bf3d74609ed7224dc66f.tar
nixlib-65e92d19d286ccce3ee7bf3d74609ed7224dc66f.tar.gz
nixlib-65e92d19d286ccce3ee7bf3d74609ed7224dc66f.tar.bz2
nixlib-65e92d19d286ccce3ee7bf3d74609ed7224dc66f.tar.lz
nixlib-65e92d19d286ccce3ee7bf3d74609ed7224dc66f.tar.xz
nixlib-65e92d19d286ccce3ee7bf3d74609ed7224dc66f.tar.zst
nixlib-65e92d19d286ccce3ee7bf3d74609ed7224dc66f.zip
Merge pull request #34968 from timokau/rust-find
buildRustPackage: Restrict `find` to files
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/rust/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/build-support/rust/default.nix b/pkgs/build-support/rust/default.nix
index f407ba25bf85..d7d03aae33ee 100644
--- a/pkgs/build-support/rust/default.nix
+++ b/pkgs/build-support/rust/default.nix
@@ -91,7 +91,7 @@ in stdenv.mkDerivation (args // {
   installPhase = args.installPhase or ''
     runHook preInstall
     mkdir -p $out/bin
-    find target/release -maxdepth 1 -executable -exec cp "{}" $out/bin \;
+    find target/release -maxdepth 1 -executable -type f -exec cp "{}" $out/bin \;
     runHook postInstall
   '';