about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorVladimír Čunát <v@cunat.cz>2019-04-06 13:20:53 +0200
committerVladimír Čunát <v@cunat.cz>2019-04-06 13:20:53 +0200
commit526c4292ae62e63b5711f8d112290fcd2613d8b3 (patch)
tree6173d194e626d9f23d530cdbaaadd9df674ce506 /pkgs/build-support
parent6fe989eaed7d283bbde7a58e42ce36c676870aee (diff)
parent6b9afd8991899e3b115cb8af5702706eb0db1933 (diff)
downloadnixlib-526c4292ae62e63b5711f8d112290fcd2613d8b3.tar
nixlib-526c4292ae62e63b5711f8d112290fcd2613d8b3.tar.gz
nixlib-526c4292ae62e63b5711f8d112290fcd2613d8b3.tar.bz2
nixlib-526c4292ae62e63b5711f8d112290fcd2613d8b3.tar.lz
nixlib-526c4292ae62e63b5711f8d112290fcd2613d8b3.tar.xz
nixlib-526c4292ae62e63b5711f8d112290fcd2613d8b3.tar.zst
nixlib-526c4292ae62e63b5711f8d112290fcd2613d8b3.zip
Merge branch 'staging-next'
This iteration was long, about five weeks (2fcb11a2), I think.
Darwin: it's missing a few thousand binaries and there's a make-netbsd
regression, but I suppose these aren't merge blockers.
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/bintools-wrapper/default.nix3
-rw-r--r--pkgs/build-support/cc-wrapper/default.nix4
2 files changed, 6 insertions, 1 deletions
diff --git a/pkgs/build-support/bintools-wrapper/default.nix b/pkgs/build-support/bintools-wrapper/default.nix
index 72327d2bb671..6406a8aa12ca 100644
--- a/pkgs/build-support/bintools-wrapper/default.nix
+++ b/pkgs/build-support/bintools-wrapper/default.nix
@@ -53,6 +53,7 @@ let
     /**/ if libc == null then null
     else if targetPlatform.libc == "musl"             then "${libc_lib}/lib/ld-musl-*"
     else if targetPlatform.libc == "bionic"           then "/system/bin/linker"
+    else if targetPlatform.libc == "nblibc"           then "${libc_lib}/libexec/ld.elf_so"
     else if targetPlatform.system == "i686-linux"     then "${libc_lib}/lib/ld-linux.so.2"
     else if targetPlatform.system == "x86_64-linux"   then "${libc_lib}/lib/ld-linux-x86-64.so.2"
     # ARM with a wildcard, which can be "" or "-armhf".
@@ -189,7 +190,7 @@ stdenv.mkDerivation {
       else if targetPlatform.isMsp430 then "msp430"
       else if targetPlatform.isAvr then "avr"
       else if targetPlatform.isAlpha then "alpha"
-      else throw "unknown emulation for platform: " + targetPlatform.config;
+      else throw "unknown emulation for platform: ${targetPlatform.config}";
     in targetPlatform.platform.bfdEmulation or (fmt + sep + arch);
 
   strictDeps = true;
diff --git a/pkgs/build-support/cc-wrapper/default.nix b/pkgs/build-support/cc-wrapper/default.nix
index 176df51cbd9a..f05b9fb22555 100644
--- a/pkgs/build-support/cc-wrapper/default.nix
+++ b/pkgs/build-support/cc-wrapper/default.nix
@@ -291,6 +291,10 @@ stdenv.mkDerivation {
       hardening_unsupported_flags+=" stackprotector pic"
     ''
 
+    + optionalString targetPlatform.isNetBSD ''
+      hardening_unsupported_flags+=" stackprotector fortify"
+    ''
+
     + optionalString (targetPlatform.libc == "newlib") ''
       hardening_unsupported_flags+=" stackprotector fortify pie pic"
     ''