about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorMarco Sirabella <marco@sirabella.org>2021-05-27 12:13:16 -0400
committerMarco Sirabella <marco@sirabella.org>2021-05-27 12:19:14 -0400
commit3a66432f2616484c880b6daea2393bf1e9425a33 (patch)
treec1ecd5697a3d2cf8c8b24509eaa5682030ec144a /pkgs/build-support
parentd8e73279b9e9dda14ba18d03f69c3747ae52a8b7 (diff)
downloadnixlib-3a66432f2616484c880b6daea2393bf1e9425a33.tar
nixlib-3a66432f2616484c880b6daea2393bf1e9425a33.tar.gz
nixlib-3a66432f2616484c880b6daea2393bf1e9425a33.tar.bz2
nixlib-3a66432f2616484c880b6daea2393bf1e9425a33.tar.lz
nixlib-3a66432f2616484c880b6daea2393bf1e9425a33.tar.xz
nixlib-3a66432f2616484c880b6daea2393bf1e9425a33.tar.zst
nixlib-3a66432f2616484c880b6daea2393bf1e9425a33.zip
php.buildPecl: Add checkPhase
Also update phpPackages' to use NO_INTERACTION
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/build-pecl.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/pkgs/build-support/build-pecl.nix b/pkgs/build-support/build-pecl.nix
index d75d3cf943a0..d3a8cc54a146 100644
--- a/pkgs/build-support/build-pecl.nix
+++ b/pkgs/build-support/build-pecl.nix
@@ -33,4 +33,5 @@ stdenv.mkDerivation (args // {
       (dep: "mkdir -p ext; ln -s ${dep.dev}/include ext/${dep.extensionName}")
       internalDeps}
   '';
+  checkPhase = "NO_INTERACTON=yes make test";
 })