about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorMaciej Krüger <mkg20001@gmail.com>2023-12-25 10:21:21 +0100
committerGitHub <noreply@github.com>2023-12-25 10:21:21 +0100
commit2e3a121acf5d9eec7fbfc37e07110148b8a60412 (patch)
tree8c1ea0c945dae3073232615ed317341401dcd63c /pkgs/build-support
parent939b69875f078b79c2b6433afff2dec6dd002e3f (diff)
parent676ef2b4b21cf98d9f0349c2763c7c016a5ae6e6 (diff)
downloadnixlib-2e3a121acf5d9eec7fbfc37e07110148b8a60412.tar
nixlib-2e3a121acf5d9eec7fbfc37e07110148b8a60412.tar.gz
nixlib-2e3a121acf5d9eec7fbfc37e07110148b8a60412.tar.bz2
nixlib-2e3a121acf5d9eec7fbfc37e07110148b8a60412.tar.lz
nixlib-2e3a121acf5d9eec7fbfc37e07110148b8a60412.tar.xz
nixlib-2e3a121acf5d9eec7fbfc37e07110148b8a60412.tar.zst
nixlib-2e3a121acf5d9eec7fbfc37e07110148b8a60412.zip
Merge pull request #276414 from linsui/dart
dart: fix fetchDartDeps
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/dart/fetch-dart-deps/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/build-support/dart/fetch-dart-deps/default.nix b/pkgs/build-support/dart/fetch-dart-deps/default.nix
index e6e5cf76a60f..29e5209a2877 100644
--- a/pkgs/build-support/dart/fetch-dart-deps/default.nix
+++ b/pkgs/build-support/dart/fetch-dart-deps/default.nix
@@ -178,7 +178,11 @@ let
 
     buildPhase = ''
       runHook preBuild
-      dart pub deps --json | jq .packages > $out
+      if [ -e ${dart}/bin/flutter ]; then
+        flutter pub deps --json | jq .packages > $out
+      else
+        dart pub deps --json | jq .packages > $out
+      fi
       runHook postBuild
     '';