about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorDaniel Goertzen <daniel.goertzen@gmail.com>2019-01-06 12:57:36 -0600
committerMatthew Bauer <mjbauer95@gmail.com>2019-01-06 12:57:36 -0600
commit1c10efc912c240901b186974b8ea4f48814c7b8b (patch)
tree25a5e4591636647e6ce9d35227737b1cfb76f14f /pkgs/build-support
parenta4250d14784e318f44d084095f9a41aa4375105b (diff)
downloadnixlib-1c10efc912c240901b186974b8ea4f48814c7b8b.tar
nixlib-1c10efc912c240901b186974b8ea4f48814c7b8b.tar.gz
nixlib-1c10efc912c240901b186974b8ea4f48814c7b8b.tar.bz2
nixlib-1c10efc912c240901b186974b8ea4f48814c7b8b.tar.lz
nixlib-1c10efc912c240901b186974b8ea4f48814c7b8b.tar.xz
nixlib-1c10efc912c240901b186974b8ea4f48814c7b8b.tar.zst
nixlib-1c10efc912c240901b186974b8ea4f48814c7b8b.zip
add generic x86_32 support (#52634)
* add generic x86_32 support

- Add support for i386-i586.
- Add `isx86_32` predicate that can replace most uses of `isi686`.
- `isi686` is reinterpreted to mean "exactly i686 arch, and not say i585 or i386".
- This branch was used to build working i586 kernel running on i586 hardware.

* revert `isi[345]86`, remove dead code

- Remove changes to dead code in `doubles.nix` and `for-meta.nix`.
- Remove `isi[345]86` predicates since other cpu families don't have specific model predicates.

* remove i386-linux since linux not supported on that cpu
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/bintools-wrapper/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/build-support/bintools-wrapper/default.nix b/pkgs/build-support/bintools-wrapper/default.nix
index 620ea530fc55..4122af898de9 100644
--- a/pkgs/build-support/bintools-wrapper/default.nix
+++ b/pkgs/build-support/bintools-wrapper/default.nix
@@ -177,7 +177,7 @@ stdenv.mkDerivation {
       /**/ if targetPlatform.isAarch64 then endianPrefix + "aarch64"
       else if targetPlatform.isAarch32     then endianPrefix + "arm"
       else if targetPlatform.isx86_64  then "x86-64"
-      else if targetPlatform.isx86     then "i386"
+      else if targetPlatform.isx86_32  then "i386"
       else if targetPlatform.isMips    then {
           "mips"     = "btsmipn32"; # n32 variant
           "mipsel"   = "ltsmipn32"; # n32 variant