about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2021-05-01 03:03:19 +0000
committerJohn Ericson <John.Ericson@Obsidian.Systems>2021-05-14 21:29:51 +0000
commit18c38f8aee732b6202042383fc35997a39361830 (patch)
tree466554af31e75e2739adbc2f236206e37eb72fad /pkgs/build-support
parente3a1c149d26bd82c4b42ba5e06fec73933ce8bf6 (diff)
downloadnixlib-18c38f8aee732b6202042383fc35997a39361830.tar
nixlib-18c38f8aee732b6202042383fc35997a39361830.tar.gz
nixlib-18c38f8aee732b6202042383fc35997a39361830.tar.bz2
nixlib-18c38f8aee732b6202042383fc35997a39361830.tar.lz
nixlib-18c38f8aee732b6202042383fc35997a39361830.tar.xz
nixlib-18c38f8aee732b6202042383fc35997a39361830.tar.zst
nixlib-18c38f8aee732b6202042383fc35997a39361830.zip
treewide: All the linker to be chosen independently
This will begin the process of breaking up the `useLLVM` monolith. That
is good in general, but I hope will be good for NetBSD and Darwin in
particular.

Co-authored-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/cc-wrapper/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/pkgs/build-support/cc-wrapper/default.nix b/pkgs/build-support/cc-wrapper/default.nix
index d2941b537b77..235d244a7c0d 100644
--- a/pkgs/build-support/cc-wrapper/default.nix
+++ b/pkgs/build-support/cc-wrapper/default.nix
@@ -64,6 +64,7 @@ let
 
   useGccForLibs = isClang
     && libcxx == null
+    && !stdenv.targetPlatform.isDarwin
     && !(stdenv.targetPlatform.useLLVM or false)
     && !(stdenv.targetPlatform.useAndroidPrebuilt or false)
     && !(stdenv.targetPlatform.isiOS or false)