about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2015-10-06 15:03:26 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-10-06 15:03:26 +0200
commit106738b1962829cf5cdefc321cce00b028f1210d (patch)
tree5160cd9a998f160b59c57dabe657966923da9b6f /pkgs/build-support
parent0f90d10d0b52a1aa60857a49fbfdb73c5eb78ce4 (diff)
downloadnixlib-106738b1962829cf5cdefc321cce00b028f1210d.tar
nixlib-106738b1962829cf5cdefc321cce00b028f1210d.tar.gz
nixlib-106738b1962829cf5cdefc321cce00b028f1210d.tar.bz2
nixlib-106738b1962829cf5cdefc321cce00b028f1210d.tar.lz
nixlib-106738b1962829cf5cdefc321cce00b028f1210d.tar.xz
nixlib-106738b1962829cf5cdefc321cce00b028f1210d.tar.zst
nixlib-106738b1962829cf5cdefc321cce00b028f1210d.zip
Give more memory for the disk image builder
http://hydra.nixos.org/build/26480662
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/vm/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/build-support/vm/default.nix b/pkgs/build-support/vm/default.nix
index c4fefe4d5019..95b2c161b82c 100644
--- a/pkgs/build-support/vm/default.nix
+++ b/pkgs/build-support/vm/default.nix
@@ -302,13 +302,13 @@ rec {
      `run-vm' will be left behind in the temporary build directory
      that allows you to boot into the VM and debug it interactively. */
 
-  runInLinuxVM = drv: lib.overrideDerivation drv (attrs: {
+  runInLinuxVM = drv: lib.overrideDerivation drv ({ memSize ? 512, QEMU_OPTS ? "", args, builder, ... }: {
     requiredSystemFeatures = [ "kvm" ];
     builder = "${bash}/bin/sh";
     args = ["-e" (vmRunCommand qemuCommandLinux)];
-    origArgs = attrs.args;
-    origBuilder = attrs.builder;
-    QEMU_OPTS = "${attrs.QEMU_OPTS or ""} -m ${toString (attrs.memSize or 512)}";
+    origArgs = args;
+    origBuilder = builder;
+    QEMU_OPTS = "${QEMU_OPTS} -m ${toString memSize}";
   });