about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorGraham Christensen <graham@grahamc.com>2017-12-12 20:06:36 -0500
committerGraham Christensen <graham@grahamc.com>2017-12-12 20:06:36 -0500
commit105d9519c128a8954e5dd1616f71311ddde20cbc (patch)
treebfb3663fa37d175451e3e01fada66652e4297e7f /pkgs/build-support
parentc2b679516f79ae349421f22d4da26915eb9905e4 (diff)
parente5629dc51a313c3b99725616718d2deff49cd891 (diff)
downloadnixlib-105d9519c128a8954e5dd1616f71311ddde20cbc.tar
nixlib-105d9519c128a8954e5dd1616f71311ddde20cbc.tar.gz
nixlib-105d9519c128a8954e5dd1616f71311ddde20cbc.tar.bz2
nixlib-105d9519c128a8954e5dd1616f71311ddde20cbc.tar.lz
nixlib-105d9519c128a8954e5dd1616f71311ddde20cbc.tar.xz
nixlib-105d9519c128a8954e5dd1616f71311ddde20cbc.tar.zst
nixlib-105d9519c128a8954e5dd1616f71311ddde20cbc.zip
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/rust/cargo-vendor.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/build-support/rust/cargo-vendor.nix b/pkgs/build-support/rust/cargo-vendor.nix
index 6b50f8b83e73..9c379eaa3337 100644
--- a/pkgs/build-support/rust/cargo-vendor.nix
+++ b/pkgs/build-support/rust/cargo-vendor.nix
@@ -8,13 +8,15 @@ let
     x86_64-linux = "1hxlavcxy374yypfamlkygjg662lhll8j434qcvdawkvlidg5ii5";
     x86_64-darwin = "1jkvhh710gwjnnjx59kaplx2ncfvkx9agfa76rr94sbjqq4igddm";
   };
-  hash = hashes. ${system} or (throw "missing bootstrap hash for platform ${system}");
+  hash = hashes. ${system} or badSystem;
+
+  badSystem = throw "missing bootstrap hash for platform ${system}";
 
   platforms = {
     x86_64-linux = "x86_64-unknown-linux-musl";
     x86_64-darwin = "x86_64-apple-darwin";
   };
-  platform = platforms . ${system};
+  platform = platforms . ${system} or badSystem;
 
 in stdenv.mkDerivation {
   name = "cargo-vendor-${version}";