about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-09-18 20:43:06 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-09-18 20:52:34 +0200
commit0fdb93864ee81056238b6bdd368b5db23e8ef2cf (patch)
tree1dc9896c0cb6d4258e187197e34a5bbf78a31da7 /pkgs/build-support
parentc8ea6c07c655ba70cf46c52063276bfcfa5b1643 (diff)
parentba2b706da93847e489586a97becdc184b041248f (diff)
downloadnixlib-0fdb93864ee81056238b6bdd368b5db23e8ef2cf.tar
nixlib-0fdb93864ee81056238b6bdd368b5db23e8ef2cf.tar.gz
nixlib-0fdb93864ee81056238b6bdd368b5db23e8ef2cf.tar.bz2
nixlib-0fdb93864ee81056238b6bdd368b5db23e8ef2cf.tar.lz
nixlib-0fdb93864ee81056238b6bdd368b5db23e8ef2cf.tar.xz
nixlib-0fdb93864ee81056238b6bdd368b5db23e8ef2cf.tar.zst
nixlib-0fdb93864ee81056238b6bdd368b5db23e8ef2cf.zip
Merge new texlive infrastructure, /CC #287
Diffstat (limited to 'pkgs/build-support')
-rwxr-xr-xpkgs/build-support/buildenv/builder.pl3
-rw-r--r--pkgs/build-support/buildenv/default.nix10
2 files changed, 10 insertions, 3 deletions
diff --git a/pkgs/build-support/buildenv/builder.pl b/pkgs/build-support/buildenv/builder.pl
index a272a84261e4..fd8098caf13c 100755
--- a/pkgs/build-support/buildenv/builder.pl
+++ b/pkgs/build-support/buildenv/builder.pl
@@ -142,10 +142,11 @@ while (scalar(keys %postponed) > 0) {
 
 
 # Create the symlinks.
+my $extraPrefix = $ENV{"extraPrefix"};
 my $nrLinks = 0;
 foreach my $relName (sort keys %symlinks) {
     my ($target, $priority) = @{$symlinks{$relName}};
-    my $abs = "$out/$relName";
+    my $abs = "$out" . "$extraPrefix" . "/$relName";
     next unless isInPathsToLink $relName;
     if ($target eq "") {
         #print "creating directory $relName\n";
diff --git a/pkgs/build-support/buildenv/default.nix b/pkgs/build-support/buildenv/default.nix
index 2ae8123faca4..8cbf0dc6c8e4 100644
--- a/pkgs/build-support/buildenv/default.nix
+++ b/pkgs/build-support/buildenv/default.nix
@@ -21,14 +21,20 @@
   # directories in the list is not symlinked.
   pathsToLink ? ["/"]
 
-, # Shell command to run after building the symlink tree.
+, # Root the result in directory "$out${extraPrefix}", e.g. "/share".
+  extraPrefix ? ""
+
+, # Shell commands to run after building the symlink tree.
   postBuild ? ""
 
+, # Additional inputs. Handy e.g. if using makeWrapper in `postBuild`.
+  buildInputs ? []
+
 , passthru ? {}
 }:
 
 runCommand name
-  { inherit manifest ignoreCollisions passthru pathsToLink postBuild;
+  { inherit manifest ignoreCollisions passthru pathsToLink extraPrefix postBuild buildInputs;
     pkgs = builtins.toJSON (map (drv: {
       paths = [ drv ]; # FIXME: handle multiple outputs
       priority = drv.meta.priority or 5;