about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorDylan Simon <dylan@dylex.net>2017-12-09 01:01:39 -0500
committerOrivej Desh <orivej@gmx.fr>2017-12-17 04:23:54 +0000
commit0c62b7cd7468820456da2ec9fd1cdc0347b90cd9 (patch)
tree3a7eb188875ce8b7b6b6ecccb2e4f1343636e5c9 /pkgs/build-support
parent994a614ca3a82f3bf99d2c6504c94964955ee1ab (diff)
downloadnixlib-0c62b7cd7468820456da2ec9fd1cdc0347b90cd9.tar
nixlib-0c62b7cd7468820456da2ec9fd1cdc0347b90cd9.tar.gz
nixlib-0c62b7cd7468820456da2ec9fd1cdc0347b90cd9.tar.bz2
nixlib-0c62b7cd7468820456da2ec9fd1cdc0347b90cd9.tar.lz
nixlib-0c62b7cd7468820456da2ec9fd1cdc0347b90cd9.tar.xz
nixlib-0c62b7cd7468820456da2ec9fd1cdc0347b90cd9.tar.zst
nixlib-0c62b7cd7468820456da2ec9fd1cdc0347b90cd9.zip
cc-wrapper: don't set cxx_stdlib when nativeTools is true
There are no gcc paths on nativeTools, and cc isn't set.
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/cc-wrapper/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/build-support/cc-wrapper/default.nix b/pkgs/build-support/cc-wrapper/default.nix
index b79697b33f0c..2539f52accf0 100644
--- a/pkgs/build-support/cc-wrapper/default.nix
+++ b/pkgs/build-support/cc-wrapper/default.nix
@@ -46,7 +46,7 @@ let
   # The wrapper scripts use 'cat' and 'grep', so we may need coreutils.
   coreutils_bin = if nativeTools then "" else getBin coreutils;
 
-  default_cxx_stdlib_compile=optionalString (targetPlatform.isLinux && !(cc.isGNU or false))
+  default_cxx_stdlib_compile = optionalString (targetPlatform.isLinux && !(cc.isGNU or false) && !nativeTools)
     "-isystem $(echo -n ${cc.gcc}/include/c++/*) -isystem $(echo -n ${cc.gcc}/include/c++/*)/$(${cc.gcc}/bin/gcc -dumpmachine)";
 
   dashlessTarget = stdenv.lib.replaceStrings ["-"] ["_"] targetPlatform.config;