about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorhyperfekt <git@hyperfekt.net>2020-06-07 19:51:13 +0200
committerehmry <ehmry@posteo.net>2020-06-08 10:05:00 +0530
commit0a8fb89fca5bb1fee4e015e52f003746fd4ec682 (patch)
tree571281ff6152b704037f37ccf09b61c123e61b56 /pkgs/build-support
parent92c3267ad4adcf5db15baf2cbb25c15f65b6b86f (diff)
downloadnixlib-0a8fb89fca5bb1fee4e015e52f003746fd4ec682.tar
nixlib-0a8fb89fca5bb1fee4e015e52f003746fd4ec682.tar.gz
nixlib-0a8fb89fca5bb1fee4e015e52f003746fd4ec682.tar.bz2
nixlib-0a8fb89fca5bb1fee4e015e52f003746fd4ec682.tar.lz
nixlib-0a8fb89fca5bb1fee4e015e52f003746fd4ec682.tar.xz
nixlib-0a8fb89fca5bb1fee4e015e52f003746fd4ec682.tar.zst
nixlib-0a8fb89fca5bb1fee4e015e52f003746fd4ec682.zip
rustPlatform: fix cross-compiling by using native diff
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/rust/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/build-support/rust/default.nix b/pkgs/build-support/rust/default.nix
index 795ce841ffb6..770a6d1042e7 100644
--- a/pkgs/build-support/rust/default.nix
+++ b/pkgs/build-support/rust/default.nix
@@ -70,7 +70,8 @@ let
 
   # Specify the stdenv's `diff` by abspath to ensure that the user's build
   # inputs do not cause us to find the wrong `diff`.
-  diff = "${diffutils}/bin/diff";
+  # The `.nativeDrv` stanza works like nativeBuildInputs and ensures cross-compiling has the right version available.
+  diff = "${diffutils.nativeDrv or diffutils}/bin/diff";
 
 in