about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorElis Hirwing <elis@hirwing.se>2019-06-12 13:14:22 +0200
committerGitHub <noreply@github.com>2019-06-12 13:14:22 +0200
commit039983bd7a491e0ce9eebff761e7b9c3cce6b696 (patch)
tree359d8b5da972b4410ed49c144551d8adf88d5dfe /pkgs/build-support
parent734b3e7758d988b88b77fc2f3d3aed7a3d79cf2d (diff)
parentd61323992e833c75e83882dababc3788634ab8b8 (diff)
downloadnixlib-039983bd7a491e0ce9eebff761e7b9c3cce6b696.tar
nixlib-039983bd7a491e0ce9eebff761e7b9c3cce6b696.tar.gz
nixlib-039983bd7a491e0ce9eebff761e7b9c3cce6b696.tar.bz2
nixlib-039983bd7a491e0ce9eebff761e7b9c3cce6b696.tar.lz
nixlib-039983bd7a491e0ce9eebff761e7b9c3cce6b696.tar.xz
nixlib-039983bd7a491e0ce9eebff761e7b9c3cce6b696.tar.zst
nixlib-039983bd7a491e0ce9eebff761e7b9c3cce6b696.zip
Merge pull request #62783 from Izorkin/php-packages
php: update build config and php package
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/build-pecl.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/build-support/build-pecl.nix b/pkgs/build-support/build-pecl.nix
index d08f8822d751..a1030e3b34fa 100644
--- a/pkgs/build-support/build-pecl.nix
+++ b/pkgs/build-support/build-pecl.nix
@@ -1,4 +1,4 @@
-{ stdenv, php, autoreconfHook, fetchurl }:
+{ stdenv, php, autoreconfHook, fetchurl, re2c }:
 
 { pname
 , version
@@ -17,7 +17,7 @@ stdenv.mkDerivation (args // {
 
   inherit src;
 
-  nativeBuildInputs = [ autoreconfHook ] ++ nativeBuildInputs;
+  nativeBuildInputs = [ autoreconfHook re2c ] ++ nativeBuildInputs;
   buildInputs = [ php ] ++ buildInputs;
 
   makeFlags = [ "EXTENSION_DIR=$(out)/lib/php/extensions" ] ++ makeFlags;