about summary refs log tree commit diff
path: root/pkgs/build-support
diff options
context:
space:
mode:
authorLassulus <github@lassul.us>2020-12-15 22:16:48 +0100
committerGitHub <noreply@github.com>2020-12-15 22:16:48 +0100
commit00b8fa792b2d39ef1b42848059ff15d50341decc (patch)
tree351bdd6d9d78e76a0bd07fbdd9c4fe9605e818f2 /pkgs/build-support
parentde8205f8bb2c6ca14730b00ba3a280db1d364b40 (diff)
parent1c8c134972b64aa31ceddc2b5054ff664e396910 (diff)
downloadnixlib-00b8fa792b2d39ef1b42848059ff15d50341decc.tar
nixlib-00b8fa792b2d39ef1b42848059ff15d50341decc.tar.gz
nixlib-00b8fa792b2d39ef1b42848059ff15d50341decc.tar.bz2
nixlib-00b8fa792b2d39ef1b42848059ff15d50341decc.tar.lz
nixlib-00b8fa792b2d39ef1b42848059ff15d50341decc.tar.xz
nixlib-00b8fa792b2d39ef1b42848059ff15d50341decc.tar.zst
nixlib-00b8fa792b2d39ef1b42848059ff15d50341decc.zip
Merge pull request #106000 from Luis-Hebendanz/firefoxWrapperAddonSettings
firefox: wrapper updating an addon perserves addon settings
Diffstat (limited to 'pkgs/build-support')
-rw-r--r--pkgs/build-support/fetchfirefoxaddon/default.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/pkgs/build-support/fetchfirefoxaddon/default.nix b/pkgs/build-support/fetchfirefoxaddon/default.nix
index 4b7c68484d2e..9efe9197d687 100644
--- a/pkgs/build-support/fetchfirefoxaddon/default.nix
+++ b/pkgs/build-support/fetchfirefoxaddon/default.nix
@@ -1,16 +1,20 @@
 {stdenv, lib, coreutils, unzip, jq, zip, fetchurl,writeScript,  ...}:
-{ name
+
+{
+  name
 , url
 , md5 ? ""
 , sha1 ? ""
 , sha256 ? ""
 , sha512 ? ""
+, fixedExtid ? null
 , hash ? ""
 }:
+
 stdenv.mkDerivation rec {
 
   inherit name;
-  extid = "${src.outputHash}@${name}";
+  extid = if fixedExtid == null then "nixos@${name}" else fixedExtid;
   passthru = {
     exitd=extid;
   };
@@ -35,4 +39,3 @@ stdenv.mkDerivation rec {
   };
   nativeBuildInputs = [ coreutils unzip zip jq  ];
 }
-