about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-07-07 18:35:50 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-07-07 18:37:04 +0200
commitff5423cdca4adc5a18463be1aa1dd1603453c724 (patch)
treedd06d7994563d6e1acfd28e63ab5d2b3a49f26f1 /pkgs/applications
parentbdabf6a6f2d6652aa5329b0a76e2972dd80c204d (diff)
downloadnixlib-ff5423cdca4adc5a18463be1aa1dd1603453c724.tar
nixlib-ff5423cdca4adc5a18463be1aa1dd1603453c724.tar.gz
nixlib-ff5423cdca4adc5a18463be1aa1dd1603453c724.tar.bz2
nixlib-ff5423cdca4adc5a18463be1aa1dd1603453c724.tar.lz
nixlib-ff5423cdca4adc5a18463be1aa1dd1603453c724.tar.xz
nixlib-ff5423cdca4adc5a18463be1aa1dd1603453c724.tar.zst
nixlib-ff5423cdca4adc5a18463be1aa1dd1603453c724.zip
calibre: use bundled html5lib
The bundled html5lib may be old and insecure, but that's all upstream
supports. Since dependencies are now requiring a newer html5lib we have
no choice but to let it use the bundled version.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/calibre/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/applications/misc/calibre/default.nix b/pkgs/applications/misc/calibre/default.nix
index f4cbc142d6b4..37cb027aa36c 100644
--- a/pkgs/applications/misc/calibre/default.nix
+++ b/pkgs/applications/misc/calibre/default.nix
@@ -5,12 +5,12 @@
 }:
 
 stdenv.mkDerivation rec {
-  version = "3.1.1";
+  version = "3.3.0";
   name = "calibre-${version}";
 
   src = fetchurl {
     url = "https://download.calibre-ebook.com/${version}/${name}.tar.xz";
-    sha256 = "1lh1gz0915r49igfhy1icz79qx36s3d8m32qlih0g3zn7jahp86g";
+    sha256 = "1zq3aihnyxdczdz8b0w02xfw4b0l9i23f6ljpmsmm69jyh4j3m0c";
   };
 
   patches = [
@@ -36,7 +36,7 @@ stdenv.mkDerivation rec {
 
     # Remove unneeded files and libs
     rm -rf resources/calibre-portable.* \
-           src/{chardet,cherrypy,html5lib,odf,routes}
+           src/{chardet,cherrypy,odf,routes}
   '';
 
   dontUseQmakeConfigure = true;
@@ -53,7 +53,7 @@ stdenv.mkDerivation rec {
     python pyqt5 sip
     regex msgpack
     # the following are distributed with calibre, but we use upstream instead
-    chardet cherrypy html5lib_0_9999999 odfpy routes
+    chardet cherrypy odfpy routes
   ]);
 
   installPhase = ''