about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJonathan Ringer <jonringer117@gmail.com>2019-08-26 11:05:40 -0700
committerLassulus <github@lassul.us>2019-10-03 00:19:33 +0200
commitfe24628a26e203e4c94147234b27df81496f6e12 (patch)
tree74c519b8af1a63085aca4583648db414419e5e4f /pkgs/applications
parentd33e497b1b450e1c1140376903e82ce07b526178 (diff)
downloadnixlib-fe24628a26e203e4c94147234b27df81496f6e12.tar
nixlib-fe24628a26e203e4c94147234b27df81496f6e12.tar.gz
nixlib-fe24628a26e203e4c94147234b27df81496f6e12.tar.bz2
nixlib-fe24628a26e203e4c94147234b27df81496f6e12.tar.lz
nixlib-fe24628a26e203e4c94147234b27df81496f6e12.tar.xz
nixlib-fe24628a26e203e4c94147234b27df81496f6e12.tar.zst
nixlib-fe24628a26e203e4c94147234b27df81496f6e12.zip
git-up: 1.4.2 -> 1.6.1
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/git-up/default.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/pkgs/applications/version-management/git-up/default.nix b/pkgs/applications/version-management/git-up/default.nix
index ba0625c433de..5812ff8c1d1d 100644
--- a/pkgs/applications/version-management/git-up/default.nix
+++ b/pkgs/applications/version-management/git-up/default.nix
@@ -1,17 +1,18 @@
-{ stdenv, fetchurl, python2Packages, git }:
+{ stdenv, fetchurl, pythonPackages, git }:
 
-python2Packages.buildPythonApplication rec {
-  version = "1.4.2";
+pythonPackages.buildPythonApplication rec {
   pname = "git-up";
+  version = "1.6.1";
 
-  src = fetchurl {
-    url = "mirror://pypi/g/git-up/${pname}-${version}.zip";
-    sha256 = "121ia5gyjy7js6fbsx9z98j2qpq7rzwpsj8gnfvsbz2d69g0vl7q";
+  src = pythonPackages.fetchPypi {
+    inherit pname version;
+    sha256 = "0gs791yb0cndg9879vayvcj329jwhzpk6wrf9ri12l5hg8g490za";
   };
 
-  buildInputs = [ git ] ++ (with python2Packages; [ nose ]);
-  propagatedBuildInputs = with python2Packages; [ click colorama docopt GitPython six termcolor ];
+  # git should be on path for tool to work correctly
+  propagatedBuildInputs = [ git ] ++ (with pythonPackages; [ click colorama docopt GitPython six termcolor ]);
 
+  checkInputs = [ git pythonPackages.nose ]; # git needs to be on path
   # 1. git fails to run as it cannot detect the email address, so we set it
   # 2. $HOME is by default not a valid dir, so we have to set that too
   # https://github.com/NixOS/nixpkgs/issues/12591
@@ -22,7 +23,7 @@ python2Packages.buildPythonApplication rec {
     '';
 
   postInstall = ''
-    rm -r $out/${python2Packages.python.sitePackages}/PyGitUp/tests
+    rm -r $out/${pythonPackages.python.sitePackages}/PyGitUp/tests
   '';
 
   meta = with stdenv.lib; {
@@ -31,6 +32,5 @@ python2Packages.buildPythonApplication rec {
     license = licenses.mit;
     maintainers = with maintainers; [ peterhoeg ];
     platforms = platforms.all;
-    broken = true; # Incompatible with Git 2.15 object store.
   };
 }