about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-11-20 11:47:26 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-11-20 11:47:26 +0100
commitfd26e7be2ac1ec17e0f170dc011dfaf0545c5c80 (patch)
treeae8f75943fe2c587ec466358dccb5bddc97c149e /pkgs/applications
parent5767ea8955809e11fd28af774c54bef8d86b737f (diff)
parent119e4e30c8285c456a07a747bb8fce5c1c1a4b3d (diff)
downloadnixlib-fd26e7be2ac1ec17e0f170dc011dfaf0545c5c80.tar
nixlib-fd26e7be2ac1ec17e0f170dc011dfaf0545c5c80.tar.gz
nixlib-fd26e7be2ac1ec17e0f170dc011dfaf0545c5c80.tar.bz2
nixlib-fd26e7be2ac1ec17e0f170dc011dfaf0545c5c80.tar.lz
nixlib-fd26e7be2ac1ec17e0f170dc011dfaf0545c5c80.tar.xz
nixlib-fd26e7be2ac1ec17e0f170dc011dfaf0545c5c80.tar.zst
nixlib-fd26e7be2ac1ec17e0f170dc011dfaf0545c5c80.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/altcoins/nano-wallet/default.nix4
-rw-r--r--pkgs/applications/audio/padthv1/default.nix4
-rw-r--r--pkgs/applications/audio/pulseeffects/default.nix4
-rw-r--r--pkgs/applications/graphics/feh/default.nix4
-rw-r--r--pkgs/applications/misc/dbeaver/default.nix4
-rw-r--r--pkgs/applications/misc/mwic/default.nix4
-rw-r--r--pkgs/applications/networking/browsers/chromium/common.nix4
-rw-r--r--pkgs/applications/networking/browsers/chromium/upstream-info.nix18
-rw-r--r--pkgs/applications/networking/cluster/terraform/default.nix34
-rw-r--r--pkgs/applications/networking/cluster/terragrunt/0.11.1.nix35
-rw-r--r--pkgs/applications/networking/cluster/terragrunt/0.9.8.nix35
-rw-r--r--pkgs/applications/networking/cluster/terragrunt/default.nix4
-rw-r--r--pkgs/applications/networking/cluster/terragrunt/deps_0_11.nix111
-rw-r--r--pkgs/applications/networking/mailreaders/trojita/default.nix11
-rw-r--r--pkgs/applications/office/bookworm/default.nix16
-rw-r--r--pkgs/applications/office/planner/default.nix22
-rw-r--r--pkgs/applications/science/logic/ltl2ba/default.nix4
-rw-r--r--pkgs/applications/science/math/gmsh/default.nix4
-rw-r--r--pkgs/applications/video/makemkv/default.nix17
19 files changed, 72 insertions, 267 deletions
diff --git a/pkgs/applications/altcoins/nano-wallet/default.nix b/pkgs/applications/altcoins/nano-wallet/default.nix
index 22da11cdd63b..62e725928741 100644
--- a/pkgs/applications/altcoins/nano-wallet/default.nix
+++ b/pkgs/applications/altcoins/nano-wallet/default.nix
@@ -3,13 +3,13 @@
 stdenv.mkDerivation rec {
 
   name = "nano-wallet-${version}";
-  version = "16.2";
+  version = "16.3";
 
   src = fetchFromGitHub {
     owner = "nanocurrency";
     repo = "raiblocks";
     rev = "V${version}";
-    sha256 = "18zp4xl5iwwrnzrqzsygdrym5565v8dpfz0jxczw21896kw1i9i7";
+    sha256 = "1rhq7qzfd8li33pmzcjxrhbbgdklxlcijam62s385f8yqjwy80dz";
     fetchSubmodules = true;
   };
 
diff --git a/pkgs/applications/audio/padthv1/default.nix b/pkgs/applications/audio/padthv1/default.nix
index ece0a70a7e97..5d74db5ec3e0 100644
--- a/pkgs/applications/audio/padthv1/default.nix
+++ b/pkgs/applications/audio/padthv1/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "padthv1-${version}";
-  version = "0.9.2";
+  version = "0.9.3";
 
   src = fetchurl {
     url = "mirror://sourceforge/padthv1/${name}.tar.gz";
-    sha256 = "1alfl0l5qdll0w5lwhrwzj5dina1big1zmjg5imi9h06dzhz51xl";
+    sha256 = "157w28wxggqpqkibz716v3r756q2z78g70ipncpalchb9dfr42b6";
   };
 
   buildInputs = [ libjack2 alsaLib libsndfile liblo lv2 qt5.qtbase qt5.qttools fftw ];
diff --git a/pkgs/applications/audio/pulseeffects/default.nix b/pkgs/applications/audio/pulseeffects/default.nix
index a5dae1d05607..659c0a71e27f 100644
--- a/pkgs/applications/audio/pulseeffects/default.nix
+++ b/pkgs/applications/audio/pulseeffects/default.nix
@@ -44,13 +44,13 @@ let
   ];
 in stdenv.mkDerivation rec {
   name = "pulseeffects-${version}";
-  version = "4.3.9";
+  version = "4.4.0";
 
   src = fetchFromGitHub {
     owner = "wwmm";
     repo = "pulseeffects";
     rev = "v${version}";
-    sha256 = "1vir05hy2n0nk0gaqbn680bx53ixcyi2y0hq4grgm73bbb1jzqq6";
+    sha256 = "0bjzlqyvcp9hxaq07nqr14k9kvan5myaxb7ci30gz0fgayib85lv";
   };
 
   nativeBuildInputs = [
diff --git a/pkgs/applications/graphics/feh/default.nix b/pkgs/applications/graphics/feh/default.nix
index 5146919fde6c..8938df4d42de 100644
--- a/pkgs/applications/graphics/feh/default.nix
+++ b/pkgs/applications/graphics/feh/default.nix
@@ -6,11 +6,11 @@ with stdenv.lib;
 
 stdenv.mkDerivation rec {
   name = "feh-${version}";
-  version = "2.28.1";
+  version = "3.0";
 
   src = fetchurl {
     url = "https://feh.finalrewind.org/${name}.tar.bz2";
-    sha256 = "0wian0gnx0yfxf8x9b8wr57fjd6rnmi3y3xj83ni6x0xqrjnf1lp";
+    sha256 = "00fwf8yz7k8vzd30ly5ndlj6ax9w85dkjzjnlk95vd0zdrf4wyxn";
   };
 
   outputs = [ "out" "man" "doc" ];
diff --git a/pkgs/applications/misc/dbeaver/default.nix b/pkgs/applications/misc/dbeaver/default.nix
index f7c1990ef3c8..03d34558413e 100644
--- a/pkgs/applications/misc/dbeaver/default.nix
+++ b/pkgs/applications/misc/dbeaver/default.nix
@@ -7,7 +7,7 @@
 
 stdenv.mkDerivation rec {
   name = "dbeaver-ce-${version}";
-  version = "5.2.4";
+  version = "5.2.5";
 
   desktopItem = makeDesktopItem {
     name = "dbeaver";
@@ -30,7 +30,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "https://dbeaver.io/files/${version}/dbeaver-ce-${version}-linux.gtk.x86_64.tar.gz";
-    sha256 = "1zwbqr5s76r77x7klydpqbaqakzzilzv92ddyck1sj5jiy5prwpp";
+    sha256 = "0xjggjq2brhi9x3i4d7hqfi18cd8czs6rzvihvspfxaqilsai0dm";
   };
 
   installPhase = ''
diff --git a/pkgs/applications/misc/mwic/default.nix b/pkgs/applications/misc/mwic/default.nix
index 15904ab7c0ab..d15382619397 100644
--- a/pkgs/applications/misc/mwic/default.nix
+++ b/pkgs/applications/misc/mwic/default.nix
@@ -1,12 +1,12 @@
 { stdenv, fetchurl, pythonPackages }:
 
 stdenv.mkDerivation rec {
-  version = "0.7.6";
+  version = "0.7.7";
   name = "mwic-${version}";
 
   src = fetchurl {
     url = "https://github.com/jwilk/mwic/releases/download/${version}/${name}.tar.gz";
-    sha256 = "0dl56979i54hrmz5l27c4q1f7jd1bpkmi7sm86946dagi4l1ns3i";
+    sha256 = "0l4anwiiqclymx0awwn4hzaj8n26ycg8nz76wjphsyscn7z2awad";
   };
 
   makeFlags=["PREFIX=\${out}"];
diff --git a/pkgs/applications/networking/browsers/chromium/common.nix b/pkgs/applications/networking/browsers/chromium/common.nix
index 661985086061..aa59daa168e2 100644
--- a/pkgs/applications/networking/browsers/chromium/common.nix
+++ b/pkgs/applications/networking/browsers/chromium/common.nix
@@ -15,6 +15,7 @@
 , libXScrnSaver, libXcursor, libXtst, libGLU_combined
 , protobuf, speechd, libXdamage, cups
 , ffmpeg, libxslt, libxml2, at-spi2-core
+, jdk
 
 # optional dependencies
 , libgcrypt ? null # gnomeSupport || cupsSupport
@@ -125,7 +126,8 @@ let
       ++ optionals gnomeSupport [ gnome.GConf libgcrypt ]
       ++ optionals cupsSupport [ libgcrypt cups ]
       ++ optional pulseSupport libpulseaudio
-      ++ optional (versionAtLeast version "71") at-spi2-core;
+      ++ optional (versionAtLeast version "71") at-spi2-core
+      ++ optional (versionAtLeast version "72") jdk.jre;
 
     patches = optional enableWideVine ./patches/widevine.patch ++ [
       ./patches/nix_plugin_paths_68.patch
diff --git a/pkgs/applications/networking/browsers/chromium/upstream-info.nix b/pkgs/applications/networking/browsers/chromium/upstream-info.nix
index 9f6e304c21e6..c2a73480b987 100644
--- a/pkgs/applications/networking/browsers/chromium/upstream-info.nix
+++ b/pkgs/applications/networking/browsers/chromium/upstream-info.nix
@@ -1,18 +1,18 @@
 # This file is autogenerated from update.sh in the same directory.
 {
   beta = {
-    sha256 = "04y78dqm19cr5929l727fk0jqqsdfyrdv50gippg32dplvw0r4fw";
-    sha256bin64 = "1rfclq9vwj61pv1sqpa4v26iby02j05lad673c79f0032v2v2r43";
-    version = "71.0.3578.44";
+    sha256 = "0nxxqfncw9ci3rhg8fiqaxy6zvh9x3j10lw8yw7c0cg2yni10qsp";
+    sha256bin64 = "0frcaplyzhkxzzcfcf0vigqpzixar4jg9hhrh4i8z8vx2gnxkwwy";
+    version = "71.0.3578.53";
   };
   dev = {
-    sha256 = "1d18957kwy3hp3dhgahip3pgjhvvadix5h3mk2d7w6zdj3l8c8kq";
-    sha256bin64 = "1yny1hyis91ajn7b8v9b4fzgswzwng3rndf1jb807xd6jd461afz";
-    version = "72.0.3608.4";
+    sha256 = "11bsn77kvjqdwpiwjf4gaindfj0sx932wp6g7cald0638wdz7pqv";
+    sha256bin64 = "1j5pd8imc35ch7l3jmnmjm2yda2xzdwha5im34240wm6rrdr2v2j";
+    version = "72.0.3610.2";
   };
   stable = {
-    sha256 = "0amc3czac897mb80qcwwladmhg2yps8r2c359nzyj7i7bq1m992d";
-    sha256bin64 = "1did6kp7dhlqp7rarvly7ywb9n9hnhhb3zgpkh3yp3f2skqrr5w8";
-    version = "70.0.3538.102";
+    sha256 = "0bwlq5xii26b3yngwkwb7l2mx03c30ffpym4xg0hcci8ry7zhpj4";
+    sha256bin64 = "1gnhjbpkp2gn3y5pingwv153bakidq60pr4fj2iq1kniyllsmmpg";
+    version = "70.0.3538.110";
   };
 }
diff --git a/pkgs/applications/networking/cluster/terraform/default.nix b/pkgs/applications/networking/cluster/terraform/default.nix
index 583b6a06aeab..8c97186b59a4 100644
--- a/pkgs/applications/networking/cluster/terraform/default.nix
+++ b/pkgs/applications/networking/cluster/terraform/default.nix
@@ -58,6 +58,7 @@ let
 
           passthru = {
             withPlugins = newplugins: withPlugins (x: newplugins x ++ actualPlugins);
+            full = withPlugins lib.attrValues;
 
             # Ouch
             overrideDerivation = f: (pluggable (terraform.overrideDerivation f)).withPlugins plugins;
@@ -86,41 +87,22 @@ let
 
   plugins = removeAttrs terraform-providers ["override" "overrideDerivation" "recurseForDerivations"];
 in rec {
-  terraform_0_8_5 = generic {
-    version = "0.8.5";
-    sha256 = "1cxwv3652fpsbm2zk1akw356cd7w7vhny1623ighgbz9ha8gvg09";
-  };
-
-  terraform_0_8 = generic {
-    version = "0.8.8";
-    sha256 = "0ibgpcpvz0bmn3cw60nzsabsrxrbmmym1hv7fx6zmjxiwd68w5gb";
-  };
-
-  terraform_0_9 = generic {
-    version = "0.9.11";
-    sha256 = "045zcpd4g9c52ynhgh3213p422ahds63mzhmd2iwcmj88g8i1w6x";
-    # checks are failing again
-    doCheck = false;
-  };
-
-  terraform_0_10 = pluggable (generic {
-    version = "0.10.8";
-    sha256 = "11hhij0hq99xhwlg5dx5nv7y074x79wkr8hr3wc6ln0kwdk5scdf";
+  terraform_0_11 = pluggable (generic {
+    version = "0.11.10";
+    sha256 = "08mapla89g106bvqr41zfd7l4ki55by6207qlxq9caiha54nx4nb";
     patches = [ ./provider-path.patch ];
     passthru = { inherit plugins; };
   });
 
-  terraform_0_10-full = terraform_0_10.withPlugins lib.attrValues;
+  terraform_0_11-full = terraform_0_11.full;
 
-  terraform_0_11 = pluggable (generic {
-    version = "0.11.10";
-    sha256 = "08mapla89g106bvqr41zfd7l4ki55by6207qlxq9caiha54nx4nb";
+  terraform_0_12 = pluggable (generic {
+    version = "0.12.0-alpha2";
+    sha256 = "1rnxgwfk10b1g3jnh9gv4lqrcszhxq8shaqslml30hafs3dkg71q";
     patches = [ ./provider-path.patch ];
     passthru = { inherit plugins; };
   });
 
-  terraform_0_11-full = terraform_0_11.withPlugins lib.attrValues;
-
   # Tests that the plugins are being used. Terraform looks at the specific
   # file pattern and if the plugin is not found it will try to download it
   # from the Internet. With sandboxing enable this test will fail if that is
diff --git a/pkgs/applications/networking/cluster/terragrunt/0.11.1.nix b/pkgs/applications/networking/cluster/terragrunt/0.11.1.nix
deleted file mode 100644
index 359579c3fde8..000000000000
--- a/pkgs/applications/networking/cluster/terragrunt/0.11.1.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{ stdenv, lib, buildGoPackage, fetchFromGitHub, terraform, makeWrapper }:
-
-buildGoPackage rec {
-  name = "terragrunt-${version}";
-  version = "0.11.1";
-
-  goPackagePath = "github.com/gruntwork-io/terragrunt";
-
-  src = fetchFromGitHub {
-    rev    = "v${version}";
-    owner  = "gruntwork-io";
-    repo   = "terragrunt";
-    sha256 = "061ix4m64i8bvjpqm6hn83nnkvqrp5y0hh5gzmxiik2nz3by1rx5";
-  };
-
-  goDeps = ./deps_0_11.nix;
-
-  buildInputs = [ makeWrapper ];
-
-  preBuild = ''
-    buildFlagsArray+=("-ldflags" "-X main.VERSION=v${version}")
-  '';
-
-  postInstall = ''
-    wrapProgram $bin/bin/terragrunt \
-      --set TERRAGRUNT_TFPATH ${lib.getBin terraform}/bin/terraform
-  '';
-
-  meta = with stdenv.lib; {
-    description = "A thin wrapper for Terraform that supports locking for Terraform state and enforces best practices.";
-    homepage = https://github.com/gruntwork-io/terragrunt/;
-    license = licenses.mit;
-    maintainers = with maintainers; [ peterhoeg ];
-  };
-}
diff --git a/pkgs/applications/networking/cluster/terragrunt/0.9.8.nix b/pkgs/applications/networking/cluster/terragrunt/0.9.8.nix
deleted file mode 100644
index ec13cbe35bca..000000000000
--- a/pkgs/applications/networking/cluster/terragrunt/0.9.8.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{ stdenv, lib, buildGoPackage, fetchFromGitHub, terraform, makeWrapper }:
-
-buildGoPackage rec {
-  name = "terragrunt-${version}";
-  version = "0.9.8";
-
-  goPackagePath = "github.com/gruntwork-io/terragrunt";
-
-  src = fetchFromGitHub {
-    rev    = "v${version}";
-    owner  = "gruntwork-io";
-    repo   = "terragrunt";
-    sha256 = "0aakr17yzh5jzvlmg3pzpnsfwl31njg27bpck541492shqcqmkiz";
-  };
-
-  goDeps = ./deps.nix;
-
-  buildInputs = [ makeWrapper ];
-
-  preBuild = ''
-    buildFlagsArray+=("-ldflags" "-X main.VERSION=v${version}")
-  '';
-
-  postInstall = ''
-    wrapProgram $bin/bin/terragrunt \
-      --set TERRAGRUNT_TFPATH ${lib.getBin terraform}/bin/terraform
-  '';
-
-  meta = with stdenv.lib; {
-    description = "A thin wrapper for Terraform that supports locking for Terraform state and enforces best practices.";
-    homepage = https://github.com/gruntwork-io/terragrunt/;
-    license = licenses.mit;
-    maintainers = with maintainers; [ peterhoeg ];
-  };
-}
diff --git a/pkgs/applications/networking/cluster/terragrunt/default.nix b/pkgs/applications/networking/cluster/terragrunt/default.nix
index 1fe9ad5ccc83..cb8cae47ab36 100644
--- a/pkgs/applications/networking/cluster/terragrunt/default.nix
+++ b/pkgs/applications/networking/cluster/terragrunt/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, buildGoPackage, fetchFromGitHub, terraform-full, makeWrapper }:
+{ stdenv, lib, buildGoPackage, fetchFromGitHub, terraform, makeWrapper }:
 
 buildGoPackage rec {
   name = "terragrunt-${version}";
@@ -23,7 +23,7 @@ buildGoPackage rec {
 
   postInstall = ''
     wrapProgram $bin/bin/terragrunt \
-      --set TERRAGRUNT_TFPATH ${lib.getBin terraform-full}/bin/terraform
+      --set TERRAGRUNT_TFPATH ${lib.getBin terraform.full}/bin/terraform
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/applications/networking/cluster/terragrunt/deps_0_11.nix b/pkgs/applications/networking/cluster/terragrunt/deps_0_11.nix
deleted file mode 100644
index 5ea04d1f424e..000000000000
--- a/pkgs/applications/networking/cluster/terragrunt/deps_0_11.nix
+++ /dev/null
@@ -1,111 +0,0 @@
-# This file was generated by https://github.com/kamilchm/go2nix v1.2.0
-[
-  {
-    goPackagePath = "github.com/aws/aws-sdk-go";
-    fetch = {
-      type = "git";
-      url = "https://github.com/aws/aws-sdk-go";
-      rev = "952498f4a390118ac65ad59cbe0c8b57ed69b6b5";
-      sha256 = "03j2dn4v2wr32jd9iki68ra0r8aghy7hpad94bf8zdgsrjn6rwvj";
-    };
-  }
-  {
-    goPackagePath = "github.com/bgentry/go-netrc";
-    fetch = {
-      type = "git";
-      url = "https://github.com/bgentry/go-netrc";
-      rev = "9fd32a8b3d3d3f9d43c341bfe098430e07609480";
-      sha256 = "0dn2h8avgavqdzdqnph8bkhj35bx0wssczry1zdczr22xv650g1l";
-    };
-  }
-  {
-    goPackagePath = "github.com/go-errors/errors";
-    fetch = {
-      type = "git";
-      url = "https://github.com/go-errors/errors";
-      rev = "8fa88b06e5974e97fbf9899a7f86a344bfd1f105";
-      sha256 = "02mvb2clbmfcqb4yclv5zhs4clkk9jxi2hiawsynl5fwmgn0d3xa";
-    };
-  }
-  {
-    goPackagePath = "github.com/hashicorp/go-getter";
-    fetch = {
-      type = "git";
-      url = "https://github.com/hashicorp/go-getter";
-      rev = "90b6568eac830f62a08e8f1f46375daa63e57015";
-      sha256 = "1cl0yqlhffjmf4qan093z49i88i7wjp9lsfwfzn52sk3c09ksism";
-    };
-  }
-  {
-    goPackagePath = "github.com/hashicorp/go-version";
-    fetch = {
-      type = "git";
-      url = "https://github.com/hashicorp/go-version";
-      rev = "03c5bf6be031b6dd45afec16b1cf94fc8938bc77";
-      sha256 = "0sjq57gpfznaqdrbyb2p0bn90g9h661cvr0jrk6ngags4pbw14ik";
-    };
-  }
-  {
-    goPackagePath = "github.com/hashicorp/hcl";
-    fetch = {
-      type = "git";
-      url = "https://github.com/hashicorp/hcl";
-      rev = "392dba7d905ed5d04a5794ba89f558b27e2ba1ca";
-      sha256 = "1rfm67kma2hpakabf7hxlj196jags4rpjpcirwg4kan4g9b6j0kb";
-    };
-  }
-  {
-    goPackagePath = "github.com/mattn/go-zglob";
-    fetch = {
-      type = "git";
-      url = "https://github.com/mattn/go-zglob";
-      rev = "95345c4e1c0ebc9d16a3284177f09360f4d20fab";
-      sha256 = "012hrd67v4gp3b621rykg2kp6a7iq4dr585qavragbif0z1whckx";
-    };
-  }
-  {
-    goPackagePath = "github.com/mitchellh/go-homedir";
-    fetch = {
-      type = "git";
-      url = "https://github.com/mitchellh/go-homedir";
-      rev = "b8bc1bf767474819792c23f32d8286a45736f1c6";
-      sha256 = "13ry4lylalkh4g2vny9cxwvryslzyzwp9r92z0b10idhdq3wad1q";
-    };
-  }
-  {
-    goPackagePath = "github.com/mitchellh/go-testing-interface";
-    fetch = {
-      type = "git";
-      url = "https://github.com/mitchellh/go-testing-interface";
-      rev = "477c2d05a845d8b55912a5a7993b9b24abcc5ef8";
-      sha256 = "0llpcyiqfjdri7pba1p13maafgcyzjbd29h99b1hgj848k5avd61";
-    };
-  }
-  {
-    goPackagePath = "github.com/mitchellh/mapstructure";
-    fetch = {
-      type = "git";
-      url = "https://github.com/mitchellh/mapstructure";
-      rev = "cc8532a8e9a55ea36402aa21efdf403a60d34096";
-      sha256 = "0705c0hq7b993sabnjy65yymvpy9w1j84bg9bjczh5607z16nw86";
-    };
-  }
-  {
-    goPackagePath = "github.com/stretchr/testify";
-    fetch = {
-      type = "git";
-      url = "https://github.com/stretchr/testify";
-      rev = "4d4bfba8f1d1027c4fdbe371823030df51419987";
-      sha256 = "1d3yz1d2s88byjzmn60jbi1m9s552f7ghzbzik97fbph37i8yjhp";
-    };
-  }
-  {
-    goPackagePath = "github.com/urfave/cli";
-    fetch = {
-      type = "git";
-      url = "https://github.com/urfave/cli";
-      rev = "d70f47eeca3afd795160003bc6e28b001d60c67c";
-      sha256 = "1xm203qp4sdlvffcbag7v6mc2d6q61i25iiz3y9yqpy25jpcpgif";
-    };
-  }
-]
diff --git a/pkgs/applications/networking/mailreaders/trojita/default.nix b/pkgs/applications/networking/mailreaders/trojita/default.nix
index 26cb9e40a263..2d96d0336132 100644
--- a/pkgs/applications/networking/mailreaders/trojita/default.nix
+++ b/pkgs/applications/networking/mailreaders/trojita/default.nix
@@ -1,19 +1,19 @@
 { mkDerivation
 , lib
-, fetchgit
+, fetchurl
 , cmake
 , qtbase
 , qtwebkit
+, qttools
 }:
 
 mkDerivation rec {
   name = "trojita-${version}";
   version = "0.7";
 
-  src = fetchgit {
-    url = "https://anongit.kde.org/trojita.git";
-    rev = "065d527c63e8e4a3ca0df73994f848b52e14ed58";
-    sha256 = "1zlwhir33hha2p3l08wnb4njnfdg69j88ycf1fa4q3x86qm3r7hw";
+  src = fetchurl {
+    url = "mirror://sourceforge/trojita/trojita/${name}.tar.xz";
+    sha256 = "1n9n07md23ny6asyw0xpih37vlwzp7vawbkprl7a1bqwfa0si3g0";
   };
 
   buildInputs = [
@@ -23,6 +23,7 @@ mkDerivation rec {
 
   nativeBuildInputs = [
     cmake
+    qttools
   ];
 
 
diff --git a/pkgs/applications/office/bookworm/default.nix b/pkgs/applications/office/bookworm/default.nix
index bc2f260c7030..5719a9be0a1f 100644
--- a/pkgs/applications/office/bookworm/default.nix
+++ b/pkgs/applications/office/bookworm/default.nix
@@ -3,25 +3,17 @@
 
 stdenv.mkDerivation rec {
   pname = "bookworm";
-  version = "4f7b118281667d22f1b3205edf0b775341fa49cb";
+  version = "unstable-2018-11-19";
 
-  name = "${pname}-2018-10-21";
+  name = "${pname}-${version}";
 
   src = fetchFromGitHub {
     owner = "babluboy";
     repo = pname;
-    rev = version;
-    sha256 = "0bcyim87zk4b4xmgfs158lnds3y8jg7ppzw54kjpc9rh66fpn3b9";
+    rev = "4c3061784ff42151cac77d12bf2a28bf831fdfc5";
+    sha256 = "0yrqxa60xlvz249kx966z5krx8i7h17ac0hjgq9p8f0irzy5yp0n";
   };
 
-  # See: https://github.com/babluboy/bookworm/pull/220
-  patches = [
-    (fetchpatch {
-      url = "https://github.com/worldofpeace/bookworm/commit/b2faf685c46b95d6a2d4ec3725e4e4122b61e99a.patch";
-      sha256 = "14az86cj5j65hngfflrp1rmnrkdrhg2a8pl7www3jgfwasxay975";
-    })
-  ];
-
   nativeBuildInputs = [
     bash
     gobjectIntrospection
diff --git a/pkgs/applications/office/planner/default.nix b/pkgs/applications/office/planner/default.nix
index 358bfc380771..85dfd024d501 100644
--- a/pkgs/applications/office/planner/default.nix
+++ b/pkgs/applications/office/planner/default.nix
@@ -1,5 +1,5 @@
 { stdenv
-, fetchgit
+, fetchFromGitLab
 , pkgconfig
 , intltool
 , automake111x
@@ -10,34 +10,36 @@
 , python
 }:
 
-let version = "20170425";
+let version = "unstable-2018-03-25";
 
 in stdenv.mkDerivation {
   name = "planner-${version}";
 
-  src = fetchgit {
-    url = https://gitlab.gnome.org/GNOME/planner.git;
-    rev = "6a79647e5711b2b8d7435cacc3452e643d2f05e6";
-    sha256 = "18k40s0f665qclrzvkgyfqmvjk0nqdc8aj3m8n4ky85di4qbqlwd";
+  src = fetchFromGitLab {
+    domain = "gitlab.gnome.org";
+    owner = "GNOME";
+    repo = "planner";
+    rev = "2a2bf11d96a7f5d64f05c9053661baa848e47797";
+    sha256 = "1bhh05kkbnhibldc1fc7kv7bwf8aa1vh4q379syqd3jbas8y521g";
   };
 
-  buildInputs = with gnome2; [
+  nativeBuildInputs = with gnome2; [
     pkgconfig
     intltool
     automake111x
     autoconf
     libtool
-
     gnome-common
     gtk-doc
+    scrollkeeper
+  ];
 
+  buildInputs = with gnome2; [
     GConf
     gtk
     libgnomecanvas
     libgnomeui
     libglade
-    scrollkeeper
-
     libxslt
     python
   ];
diff --git a/pkgs/applications/science/logic/ltl2ba/default.nix b/pkgs/applications/science/logic/ltl2ba/default.nix
index f33152a8767c..c77e0327fb6b 100644
--- a/pkgs/applications/science/logic/ltl2ba/default.nix
+++ b/pkgs/applications/science/logic/ltl2ba/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "ltl2ba-${version}";
-  version = "1.2b1";
+  version = "1.2";
 
   src = fetchurl {
     url    = "http://www.lsv.ens-cachan.fr/~gastin/ltl2ba/${name}.tar.gz";
-    sha256 = "1f4jnkfkyj8lcc5qfqbiypfc11rhhpqqi6xs9xx5dysg6r6303wm";
+    sha256 = "0vzv5g7v87r41cvdafxi6yqnk7glzxrzgavy8213k59f6v11dzlx";
   };
 
   hardeningDisable = [ "format" ];
diff --git a/pkgs/applications/science/math/gmsh/default.nix b/pkgs/applications/science/math/gmsh/default.nix
index 7c8e62cc97ce..9aff8e616c80 100644
--- a/pkgs/applications/science/math/gmsh/default.nix
+++ b/pkgs/applications/science/math/gmsh/default.nix
@@ -1,14 +1,14 @@
 { stdenv, fetchurl, cmake, openblasCompat, gfortran, gmm, fltk, libjpeg
 , zlib, libGLU_combined, libGLU, xorg }:
 
-let version = "4.0.4"; in
+let version = "4.0.5"; in
 
 stdenv.mkDerivation {
   name = "gmsh-${version}";
 
   src = fetchurl {
     url = "http://gmsh.info/src/gmsh-${version}-source.tgz";
-    sha256 = "1hvrls3xyxvn69kwicpvndrs0zhifcfkhfsxr8zkmhmn6fhnjhha";
+    sha256 = "194354f5cfede4ef47cb6f1d2bde294873315a1b34be114564defef88d108adf";
   };
 
   buildInputs = [ cmake openblasCompat gmm fltk libjpeg zlib libGLU_combined
diff --git a/pkgs/applications/video/makemkv/default.nix b/pkgs/applications/video/makemkv/default.nix
index b25560c50c90..cadd3c9fc68c 100644
--- a/pkgs/applications/video/makemkv/default.nix
+++ b/pkgs/applications/video/makemkv/default.nix
@@ -4,17 +4,24 @@
 
 stdenv.mkDerivation rec {
   name = "makemkv-${ver}";
-  ver = "1.14.0";
+  ver = "1.14.1";
   builder = ./builder.sh;
 
+  # Using two URLs as the first one will break as soon as a new version is released
   src_bin = fetchurl {
-    url = "http://www.makemkv.com/download/makemkv-bin-${ver}.tar.gz";
-    sha256 = "1xm5pww6jf3m704y7d7nc2ni2a6ygxwb2c665agg2i059sppwz1f";
+    urls = [
+      "http://www.makemkv.com/download/makemkv-bin-${ver}.tar.gz"
+      "http://www.makemkv.com/download/old/makemkv-bin-${ver}.tar.gz"
+    ];
+    sha256 = "1n4gjb1531gkvnjzipw63v3zdxmrq5nai9nn6m2ix3lskksjrrhp";
   };
 
   src_oss = fetchurl {
-    url = "http://www.makemkv.com/download/makemkv-oss-${ver}.tar.gz";
-    sha256 = "1ihma2nv7zgqx1psgj3bdz723h94f4vk8mbahxl1v4v2rn9kg25z";
+    urls = [
+      "http://www.makemkv.com/download/makemkv-oss-${ver}.tar.gz"
+      "http://www.makemkv.com/download/old/makemkv-oss-${ver}.tar.gz"
+    ];
+    sha256 = "0ysb0nm11vp2ni838p5q3gqan5nrqbr7rz0h24j8p62827pib3pw";
   };
 
   nativeBuildInputs = [ pkgconfig ];