about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorSven Keidel <svenkeidel@googlemail.com>2014-08-19 23:35:33 +0200
committerVladimír Čunát <vcunat@gmail.com>2014-08-21 19:22:37 +0200
commitfc152248cea140504871893c82acc8f03c327c0a (patch)
treecfe201504a4f2b090ed80933e12eeb0ccacaddeb /pkgs/applications
parent07e130108513db4aaa24a89ff0a225d758046305 (diff)
downloadnixlib-fc152248cea140504871893c82acc8f03c327c0a.tar
nixlib-fc152248cea140504871893c82acc8f03c327c0a.tar.gz
nixlib-fc152248cea140504871893c82acc8f03c327c0a.tar.bz2
nixlib-fc152248cea140504871893c82acc8f03c327c0a.tar.lz
nixlib-fc152248cea140504871893c82acc8f03c327c0a.tar.xz
nixlib-fc152248cea140504871893c82acc8f03c327c0a.tar.zst
nixlib-fc152248cea140504871893c82acc8f03c327c0a.zip
cool-old-term: add 0.9 (close #3685, #3575)
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/cool-old-term/default.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/pkgs/applications/misc/cool-old-term/default.nix b/pkgs/applications/misc/cool-old-term/default.nix
new file mode 100644
index 000000000000..76d78f004024
--- /dev/null
+++ b/pkgs/applications/misc/cool-old-term/default.nix
@@ -0,0 +1,53 @@
+{ stdenv, fetchFromGitHub, qt53 }:
+
+stdenv.mkDerivation rec {
+  version = "0.9";
+  name = "cool-old-term-${version}";
+
+  src = fetchFromGitHub {
+    owner = "Swordifish90";
+    repo = "cool-old-term";
+    rev = "2494bc05228290545df8c59c05624a4b903e9068";
+    sha256 = "8462f3eded7b2219acc143258544b0dfac32d81e10cac61ff14276d426704c93";
+  };
+
+  buildInputs = [ qt53 ];
+
+  buildPhase = ''
+    pushd ./konsole-qml-plugin
+    qmake konsole-qml-plugin.pro PREFIX=$out
+    make
+    popd
+  '';
+
+  installPhase = ''
+    pushd ./konsole-qml-plugin
+    make install
+    popd
+
+    install -d $out/bin $out/lib/cool-old-term $out/share/cool-old-term
+    cp -a ./imports $out/lib/cool-old-term/
+    cp -a ./app     $out/share/cool-old-term/
+
+    cat > $out/bin/cool-old-term <<EOF
+    #!${stdenv.shell}
+    ${qt53}/bin/qmlscene -I $out/lib/cool-old-term/imports $out/share/cool-old-term/app/main.qml
+    EOF
+    chmod a+x $out/bin/cool-old-term
+  '';
+
+  enableParallelBuilding = true;
+
+  meta = {
+    description = "Terminal emulator which mimics the old cathode display";
+    longDescription = ''
+      cool-old-term is a terminal emulator which tries to mimic the look and
+      feel of the old cathode tube screens. It has been designed to be
+      eye-candy, customizable, and reasonably lightweight.
+    '';
+    homepage = "https://github.com/Swordifish90/cool-old-term";
+    licenses = with stdenv.lib.licenses; [ gpl2 gpl3 ];
+    platforms = stdenv.lib.platforms.linux;
+    maintainers = with stdenv.lib.maintainers; [ skeidel ];
+  };
+}