about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorLassulus <github@lassul.us>2019-10-02 23:05:10 +0200
committerGitHub <noreply@github.com>2019-10-02 23:05:10 +0200
commitf9b2528866c3d313dad731350dbac1b8978ae930 (patch)
tree04fba5fe44d0ab0a9431bf9e38c78bcaf3c53a3c /pkgs/applications
parentcdc963c5f3693eabffc9e6a3488d203d461ac09e (diff)
parentf855e588b74d1b1d3fe5aac47482a6dc17703e34 (diff)
downloadnixlib-f9b2528866c3d313dad731350dbac1b8978ae930.tar
nixlib-f9b2528866c3d313dad731350dbac1b8978ae930.tar.gz
nixlib-f9b2528866c3d313dad731350dbac1b8978ae930.tar.bz2
nixlib-f9b2528866c3d313dad731350dbac1b8978ae930.tar.lz
nixlib-f9b2528866c3d313dad731350dbac1b8978ae930.tar.xz
nixlib-f9b2528866c3d313dad731350dbac1b8978ae930.tar.zst
nixlib-f9b2528866c3d313dad731350dbac1b8978ae930.zip
Merge pull request #70168 from schmittlauch/cawbird
cawbird: init at 1.0.1, replace corebird
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/cawbird/default.nix (renamed from pkgs/applications/networking/corebird/default.nix)28
1 files changed, 14 insertions, 14 deletions
diff --git a/pkgs/applications/networking/corebird/default.nix b/pkgs/applications/networking/cawbird/default.nix
index 73c0e234945e..edcf9b2846ed 100644
--- a/pkgs/applications/networking/corebird/default.nix
+++ b/pkgs/applications/networking/cawbird/default.nix
@@ -1,20 +1,20 @@
-{ stdenv, fetchFromGitHub, glib, gtk3, json-glib, sqlite, libsoup, gettext, vala_0_40
+{ stdenv, fetchFromGitHub, glib, gtk3, json-glib, sqlite, libsoup, gettext, vala
 , meson, ninja, pkgconfig, gnome3, gst_all_1, wrapGAppsHook, gobject-introspection
 , glib-networking, python3 }:
 
 stdenv.mkDerivation rec {
-  version = "1.7.4";
-  pname = "corebird";
+  version = "1.0.1";
+  pname = "cawbird";
 
   src = fetchFromGitHub {
-    owner = "baedert";
-    repo = "corebird";
-    rev = version;
-    sha256 = "0qjffsmg1hm64dgsbkfwzbzy9q4xa1q4fh4h8ni8a2b1p3h80x7n";
+    owner = "IBBoard";
+    repo = "cawbird";
+    rev = "v${version}";
+    sha256 = "sha256:0bk33fh32nnv6ya6j0ij34abw6a3g6m8fq13303slhhja8xhvmb1";
   };
 
   nativeBuildInputs = [
-    meson ninja vala_0_40 pkgconfig wrapGAppsHook python3
+    meson ninja vala pkgconfig wrapGAppsHook python3
     gobject-introspection # for setup hook
   ];
 
@@ -27,12 +27,12 @@ stdenv.mkDerivation rec {
     patchShebangs data/meson_post_install.py
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Native GTK Twitter client for the Linux desktop";
-    longDescription = "Corebird is a modern, easy and fun Twitter client.";
-    homepage = https://corebird.baedert.org/;
-    license = stdenv.lib.licenses.gpl3;
-    platforms = stdenv.lib.platforms.linux;
-    maintainers = [ stdenv.lib.maintainers.jonafato ];
+    longDescription = "Cawbird is a modern, easy and fun Twitter client. Fork of the discontinued Corebird.";
+    homepage = https://ibboard.co.uk/cawbird/;
+    license = licenses.gpl3;
+    platforms = platforms.linux;
+    maintainers = with stdenv.lib.maintainers; [ jonafato schmittlauch ];
   };
 }