about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2009-09-25 15:24:31 +0000
committerLudovic Courtès <ludo@gnu.org>2009-09-25 15:24:31 +0000
commitf8836a2e41466b9829022f43be9700a79a53daf5 (patch)
tree1a18b32df3da68977837012564628d3e6455d2c8 /pkgs/applications
parent5873baddb7aeb1c77df98df80b7d8e1f346f9fa1 (diff)
downloadnixlib-f8836a2e41466b9829022f43be9700a79a53daf5.tar
nixlib-f8836a2e41466b9829022f43be9700a79a53daf5.tar.gz
nixlib-f8836a2e41466b9829022f43be9700a79a53daf5.tar.bz2
nixlib-f8836a2e41466b9829022f43be9700a79a53daf5.tar.lz
nixlib-f8836a2e41466b9829022f43be9700a79a53daf5.tar.xz
nixlib-f8836a2e41466b9829022f43be9700a79a53daf5.tar.zst
nixlib-f8836a2e41466b9829022f43be9700a79a53daf5.zip
GNU Gnash 0.8.6.
svn path=/nixpkgs/trunk/; revision=17421
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/video/gnash/builder.sh11
-rw-r--r--pkgs/applications/video/gnash/default.nix25
2 files changed, 29 insertions, 7 deletions
diff --git a/pkgs/applications/video/gnash/builder.sh b/pkgs/applications/video/gnash/builder.sh
index c86884d58ef2..411b86d68a16 100644
--- a/pkgs/applications/video/gnash/builder.sh
+++ b/pkgs/applications/video/gnash/builder.sh
@@ -1,5 +1,14 @@
 source "$stdenv/setup"
 
-configureFlags="--with-sdl-incl=$SDL/include/SDL --with-npapi-plugindir=$out/plugins --enable-gui=gtk"
+configureFlags="					\
+  --with-sdl-incl=$SDL/include/SDL			\
+  --with-npapi-plugindir=$out/plugins			\
+  --enable-media=gst					\
+  --enable-gui=gtk"
+
+# In `libmedia', Gnash compiles with "-I$gstPluginsBase/include",
+# whereas it really needs "-I$gstPluginsBase/include/gstreamer-0.10".
+# Work around this using GCC's $CPATH variable.
+export CPATH="$gstPluginsBase/include/gstreamer-0.10"
 
 genericBuild
diff --git a/pkgs/applications/video/gnash/default.nix b/pkgs/applications/video/gnash/default.nix
index 3e358c486876..8b6ac0c451b5 100644
--- a/pkgs/applications/video/gnash/default.nix
+++ b/pkgs/applications/video/gnash/default.nix
@@ -7,14 +7,14 @@
 
 assert stdenv ? glibc;
 
-let version = "0.8.5"; in
+let version = "0.8.6"; in
 
 stdenv.mkDerivation rec {
   name = "gnash-${version}";
 
   src = fetchurl {
     url = "mirror://gnu/gnash/${version}/${name}.tar.bz2";
-    sha256 = "1cqhnbp99rb0n4x2bsz8wwh7vvc2kclxc1wmrl5vaapd9qhp5whn";
+    sha256 = "1sijafl5c5a005p8jxgn1cdmxkj7a6142dklrlzm9g55n9gbgx05";
   };
 
   builder = ./builder.sh;
@@ -47,7 +47,7 @@ stdenv.mkDerivation rec {
     ming dejagnu python
   ];
 
-  inherit SDL_mixer SDL;
+  inherit SDL_mixer SDL gstPluginsBase;
 
   # Make sure `gtk-gnash' gets `libXext' in its `RPATH'.
   NIX_LDFLAGS="-lX11 -lXext";
@@ -60,9 +60,9 @@ stdenv.mkDerivation rec {
 
     # Wrap programs so the find the GStreamer plug-ins they need
     # (e.g., gst-ffmpeg is needed to watch movies such as YouTube's).
-    for prog in $out/bin/*
+    for prog in "$out/bin/"*
     do
-      wrapProgram "$prog" --prefix                                              \
+      wrapProgram "$prog" --prefix                                            \
         GST_PLUGIN_PATH ":"                                                     \
         "${gstPluginsBase}/lib/gstreamer-0.10:${gstFfmpeg}/lib/gstreamer-0.10"
     done
@@ -70,7 +70,20 @@ stdenv.mkDerivation rec {
 
   meta = {
     homepage = http://www.gnu.org/software/gnash/;
-    description = "GNU Gnash, an SWF movie player";
+    description = "GNU Gnash, a libre SWF (Flash) movie player";
+
+    longDescription = ''
+      Gnash is a GNU Flash movie player.  Flash is an animation file format
+      pioneered by Macromedia which continues to be supported by their
+      successor company, Adobe.  Flash has been extended to include audio and
+      video content, and programs written in ActionScript, an
+      ECMAScript-compatible language.  Gnash is based on GameSWF, and
+      supports most SWF v7 features and some SWF v8 and v9.
+    '';
+
     license = "GPLv3+";
+
+    maintainers = [ stdenv.lib.maintainers.ludo ];
+    platforms = stdenv.lib.platforms.gnu;
   };
 } // {mozillaPlugin = "/plugins";}